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1  Introduction

1.1  What is the EKM

The Electronic-Key-Manager EKM is a comprehensive software solution for programming and managing
the Electronic-Key System EKS. The EKS provides access control on PCs and control units in an
industrial environment. in comparison to the issue of a password, considerably more responsibility is
assigned to the owner of an Electronic-Key. The Electronic-Key provides protection against
unauthorized access to control and visualization systems.
 
EKS basically comprises two components:
an Electronic-Key and the matching Electronic-Key adapter. It is an inductive Identification System. A
memory chip and an antenna are built into the Electronic-Key (transponder). In principle, the Electronic-
Key adapter is a read/write system with integrated evaluation unit and interface.
 

EKM supplements the EKS with a flexible, customizable software environment.
 

Benefits for you:

· Electronic-Key programming
· Database-based management of the Electronic-Keys
· Display of data and writing of data to the keys using a flexible user interface
· Expansion of the key memory areas with customizable database fields
· Role-based management of access rights
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1.2  System overview

EKM is based on a client/server architecture comprising the EKM client and the EKM server.

The Database Designer and Layout Designer are intelligent tools that enable you to design the database
and user interface and to customize them without the need for specialist knowledge. The role-based
user management makes it possible to simply and rapidly structure users into groups and to assign
user rights. This aspect includes comprehensive program functions as well as the clarity and editing
features of specific form components.

When a key is read, the data read are displayed on the customizable key data form. During this
process, the data from the key are interpreted and formatted using the format from the form. The data
can be changed on the form and transferred to the key using the write function. In parallel to writing to
the key, the key data are transferred to the EKM server where they are saved centrally in the key
database. You can access the key database and maintain the data for the Electronic-Key with the aid of
a database viewer.
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1.3  System requirements

EKM has the following system requirements (full version):

· Commercially available PC with x86/x64 processor
· Operating system Windows 7 / Windows 10 / Windows 11

Windows Server 2008 R2 / Windows Server 2012 / Windows Server 2012 R2 / Windows Server 2016 /
Windows Server 2019 / Windows Server 2022

· A network with TCP/IP protocol installed
· A serial or USB interface

To read and write Electronic-Keys, you will need an EKS Electronic-Key adapter with serial or USB
interface.
EKM can be operated with read/write Electronic-Keys.

1.4  Demo version

The demo version of the EKM allows you to test the full version of the product so that you can see for
yourself the advantages.

At a glance:

· Functionality of the full version
· Limited to 10 weeks runtime
· Data, database and forms prepared can continue to be used with the full version

The demo version has the complete functionality of the full version of the EKM. The runtime of this
version is limited to 10 weeks. The demo version has no network support: client and server must be
installed on one computer. All data prepared with the demo version can continue to be used with the full
version without problems.

The demo version is only allowed to be used for demonstration, test and evaluation purposes.
Further information can be found in the license agreement.
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1.5  Light version

The EKM Light version is a functionally restricted version based on the single-user version.

The following restrictions exist

a) in the client:

· No access to the database viewer
· No history log
· No template functions
· Export/import only for individual keys
· Only local EKM client possible

b) in the server:

· REST API not available
· No access to the server
· No display of the icon on the tray bar
· The client automatically starts the server

It is possible to upgrade to the single-user or full version. New data are saved in the database
and become visible on activation.

The TCP/IP protocol is also required for the EKM Light version.

1.6  Single-user version

The EKM single-user version is a functionally restricted version based on the full version.

The following restrictions exist

a) in the client:

· No history log
· Only local EKM client possible
· Data, database and forms prepared can continue to be used with the full version

b) in the server:

· REST API not available
· The client automatically starts the server

The single-user version has no network support: client and server must be installed on one computer. All
data prepared with the single-user version can continue to be used with the full version without problems.

The TCP/IP protocol is also required for the EKM single-user version.
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1.7  Full version

The EKM full version has a client/server architecture and full network support.

At a glance:

· Includes all documented functions
· Client/server architecture
· Network support
· REST API available
· System requirements cf."System requirements"

1.8  Explanation of symbols

The following symbols are used in this manual to identify important instructions and useful information:

Tip!
This symbol marks tips and tricks.

Information!
This symbol marks general important notes.

Attention!
This symbol marks instructions that you should perform to avoid the risk of the loss of data. This
symbol therefore appears next to notes that you must observe to be able to use the functionality of
EKM.
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2  Getting started

The "Getting started" section provides examples of the necessary steps that you must take the first
time you use EKM before you read or write Electronic-Keys. During this process, you will obtain an
overview of the basic functions of the program.

2.1  Starting program

Start EKM using the entry in the Windows Start menu. On the full version, the
EKM server must be started first. Alternatively, EKM can be started in the installation folder by double-
clicking the EKM.exe or EKMServer.exe file. Specify the connection parameters of the EKM server. Log
on as the default user ekm using the password ekm. The main EKM window opens with an empty form
area.
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2.2  Changing default user

Open the user manager using Tools -> User. Change the name and password for the default user by
clicking User on the View tab, selecting the user ekm and then clicking Edit on the User tab. The Edit
user window opens where you can enter the new user data. Assign the user to the Administratoren user
group.

If necessary, add new user groups and users and assign the appropriate rights to the individual user
groups.

When assigning rights, ensure that the Administratoren group has all available rights (cf. "Rights
available"). Leave the user manager with Close and log on as a user with administrator rights using
File ->Logon.
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2.3  Administring a database

Use Tools -> Design mode to change to the design mode. Now click the Database icon. The Database
Designer opens.

Add all the required data fields to the database. During this process, define the properties of the data
field:

· OnKey (data are written to the key)
· Field name 
· Data type 
· StartByte
· Length (if the data field is written to the key)
· BitNo (if the data type is Bit)
· DisplayType (for the data types Nibble, Byte, Word, CRC: Dec for the decimal notation and Hex for

the hexadecimal notation)
· Unique (activate to prevent duplicate entries)
· Template (activate to enable field for templates)
· History (activate to display changes in the History log)
· CSV export (yes: export column with all data, no: do not export column, header: export column

without data)

The order of the fields displayed in the database viewer is displayed in the FieldNo field. The data fields
KEYID (data type String) and LOCKED (data type Bit) are hard programmed and are not visible in the
Database Designer. Accept your entries with OK. The Database Designer is then closed.
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2.4  Designing user interface and selecting data source

Click the Layout icon. The EKM designer opens. The EKM Database and EKM Standard tabs on the
EKM Designer component bar contain various form components:
 

· EKM database components: form fields that are bound to the key database and display the data read
when the keys are edited.

· EKM standard components: fixed form components such as form field names, images, etc.

To insert form components into the key data form, click the component you require on the component
bar. Then click the form area in the position where you want to insert the form component.

You can change components added:
 

· In the component inspector, you can enter or select values for the properties
· You can move a marked component using the mouse.
· The size of a component can be reduced or increased using Shift + left/right arrow key.
· A component can be moved using Ctrl + left/right arrow key.
 

Design the form and enter the data source for all EKM database components by marking a component
and selecting a database field in the component inspector using DataBinding -> DataField .
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Ensure the database component matches the data type for the selected data field (cf. "Properties of
EKM database components").

2.5  Applying your work in the EKM Designer

Once you have finished designing the form for the key data, click Apply on the toolbar. Layout design is
closed and the program then uses the current layout in the general design mode. Click Apply on the
toolbar again. EKM changes automatically from the design mode to the read and write mode. You can
transfer the form and the database design to the EKM server and save them using Apply. A read right
and an edit right is created for all form components. To enable users to view and edit the form fields, the
related rights must be assigned to the corresponding groups.
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2.6  Assigning user rights

Open the user manager using Tools -> User. On the View tab, select the Rights option so that the rights
available are displayed in the window on the right.

Assign the rights to the user groups:

 

Allocate the right marked to the user group marked
 

Allocate all rights available to the user group marked

Close the user manager. All authorized users can now read and write keys.
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3  EKM

3.1  Installation

To install the EKM, start the installation program "Setup.exe". The installation program guides you
through the installation of the application and allows you to choose the folder for the installation and the
components installed. Please pay attention to the prompts displayed during the installation.

3.1.1  EKM files

All files used by EKM are saved in the EKM installation folder.

When EKM is installed on Windows 7, Windows Server 2008 or newer and the installation path is
"C:\Program Files\<EKM>" or "C:\Program Files (x86)\<EKM>", the operating system redirects
user-specific files to the VirtualStore. The VirtualStore is located under:
"C:\Users\<User>\AppData\Local\VirtualStore\Program Files\<EKM>".
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3.2  Migration and data transfer

In EKM versions from 1.7, new functions and protocols for transferring and saving the key data are used
to improve data security. Existing data from the previous versions will be migrated to the new formats.
To do this, you can use the same installation path as before or manually copy the "DB" folder with the
data from the previous version to the installation path of the new version. The new version saves the data
to the "ServerDatabase" sub-folder.

EKM installation path before data migration
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Data migration is also started the first time the new EKM server is started:

After the data migration, the data will be transferred to the "ServerDatabase" sub-menu. The previous
"DB" folder will be deleted, and the content will be secured in compressed form in a backup file.

  

To prevent a security risk, it is recommended to delete the old data after a data transfer or to store
them in a protected location.
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3.3  Starting program

Start EKM using the entry in the Windows Start menu. On the full version, the
EKM server must be started first. Alternatively, EKM can be started in the installation folder by double-
clicking the EKM.exe or EKMServer.exe file. The first time the program is started, the Connection
parameters EKM-Server window opens in front of the program splash screen.

Enter the IP address of the EKM server and the port for the server, and accept the values using OK. For
local operation, the IP address 127.0.0.1 can be used. If a connection is not established, please check,

· Whether the EKM server has been started.
· Whether the IP address and the port for the EKM server have been entered correctly.
· Whether the TCP/IP protocol is correctly installed.

Following successful establishment of the connection, the Logon window opens. To log on, please enter
your user name and password. If log on with key has been activated in your user profile, you can log on
by inserting your key into the EKS Electronic-Key adapter. If the key does not authorize you to log on, a
corresponding notice is displayed in the Logon window. The first time you start the program, logon as
the user ekm using the password ekm.  

The EKM main window opens. If necessary, choose a different port for the EKS Electronic-Key adapter
(cf. "EKS interface"). Then open the user manager using Tools -> User and change the data for the
default user(cf. "Managing user rights"), add new groups and users in the user manager, and manage
the user rights.

When the program is quit the connection parameters and the port set for the EKS Electronic-Key
adapter are written to the configuration file ekm.ini. You will not be prompted to enter the data again
when the program is opened; the data will be retrieved from the configuration file.
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For security reasons, do not forget to change the ekm user setup as an administrator when the
program is installed.
If support from the manufacturer is not required in the event of access problems, manufacturer
access can be deactivated (cf. "Manufacturer access")

3.3.1  Password quality

A high password quality increases the password's resistance to guessing or to automatically trying out
commonly used combinations. The use of secure passwords can be set on the EKM server (cf.EKM
server General Settings).
If inspection of the password quality by the EKM server is set, all users will be prompted to adapt the
password used to the quality requirements at the next logon.

The password must be adapted to the quality requirements in the following dialog box.
General rule: The longer, the better. Length and complexity are decisive for a good password. However,
the new password must fulfill at least the specified criteria:

·The password must consist of at least 15 characters.
· It must contain at least 1 uppercase letter, 1 lowercase letter, 1 number and 1 special character.
·Permissible special characters are ! ? @ ( ) { } [ ] \ / = ~ $ % & # * - +. , _

3.4  Quitting program

 
 
To quit the EKM, click Exit in the File menu.
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3.5  User interface

3.5.1  Main window

The EKM  window is the main window of the EKM program. It opens when the program is started:

 

 

The EKM main window is divided into the following areas:
 

� Menu bar ‚ Toolbar ƒ Status bar
 

„ Form area The data allocated to the key are displayed and can be changed in this area.
The design of this area can be customized to the user's specific needs in the
design mode.

The size of the window can only be changed in the design mode.
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3.5.2  Menus and toolbars

The menus and the toolbar contain different commands and icons depending on the mode in which you
are working. The content in the read/write mode is shown in the following as an example.
 

Menu bar and toolbar
 

The functionality on the menus and the toolbar is dependent on the user rights assigned. In the figure
shown above, a user with all administrator rights is assumed.

Menus and commands have shortcut keys: Press Alt and the letter underlined in the menu name
or command.

Status bar
 

 

The following information is displayed on the status bar:

� EKM server status The icon indicates the status of the connection to the EKM server:

Green icon: The connection to the EKM server is securely encrypted with
HTTPS. The certificate is valid and has been issued by a trustworthy certification
authority.
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Gray icon: The connection to the EKM server is encrypted with HTTPS. The
certificate has not been issued by a trustworthy certification authority.

Red icon: The connection to the EKM server is not secure with HTTP.

‚ Port selection The port selected for the EKS Electronic-Key adapter is displayed in the Port
field. You can select a different port from the drop-down list (cf."EKS interface").

ƒ User indication The name of the user logged on is displayed next to the user icon.

HTTP connections are not secure due to the lack of encryption. All data are sent in plain text and
without security mechanisms. Therefore, the use of HTTP connections is not recommended (cf.
"Data traffic encryption").

3.5.3  Language selection

You can change between German and English while the program is running.

3.6  Reading and writing

To read key data or to write keys, proceed as follows:
 

· Check the settings for the EKS Electronic-Key adapter using the manual on the EKS (key-specific
settings).

· Connect the EKS Electronic-Key adapter to a power source.
· Connect the EKS Electronic-Key adapter to a serial interface or USB interface on your computer.
· Choose the port for the serial interface.

Start the EKM or change from the design mode to the basic setting of the program.

3.6.1  Reading a key

To read a key, push the key into the EKS Electronic-Key adapter. The read process starts
automatically. Progress during the read process is displayed in Key access on the status bar.

 
When the key is read, the data on the key are automatically transferred to the EKM server database.
Once the read process is complete, the data are displayed on the key form.
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You can also start the read process manually:
 

 

Click the Read icon on the toolbar or the Read command in the Edit menu.

The data displayed on the form are overwritten on renewed reading.

Note that the read process is dependent on the activation of the field property OnKey:

OnKey activated: On reading, the value is read directly from the key, transferred to the database
and displayed on the form. If the key does not contain any valid data, a notice will be displayed
and the invalid value will be replaced by a default value. This default behavior can be changed using
the EKM server setting "Data Synchronization". With the "Database is Master" setting, the value is
transferred from the database to the key after the key has been read.

OnKey deactivated: On reading, the value is read directly from the database and displayed on the
form.

The first time fields are read without OnKey activated, the database fields are ZERO. Blank fields
are displayed on the form.
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3.6.2  Writing a key

To write to a key, push the key into the EKS Electronic-Key adapter. First, the read process
starts automatically. Then enter the data on the form (for information on data entry,cf. "Data entry").

To start the write process, click
 

 

the Write icon on the toolbar or the Write command in the Edit menu.
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The progress during the write process is displayed in Key access on the status bar.

 
 

The data are automatically transferred to the EKM database when the key is written. Once the write
process has been completed successfully, a message is displayed:

Accept the message with OK.

The key must not be removed during the write process.

The writing of duplicates to Unique fields is detected before the write process is performed: you will
receive an error message if you have entered a value that has already been used in a field with the
Unique restriction.
The write process is not executed.
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3.6.2.1  Data entry

Data entry when writing to a key varies depending on the form component.
 

� 

 
   

 cxDBTextEdit: Click the field and enter one line of text.

‚ 

   

 cxDBMemo: Click the field and enter several lines of text.

ƒ 

cxDBSpinEdit: Click one of the arrows. The number is increased or
decreased. You can also enter a number directly by clicking the field.
   

„ 

 

cxDBCheckBox: Click the check box to set or activate the defined property.
A check mark appears in the check box. To deactivate the field, click the
activated check box. The check box is now empty.
   

… 

 

cxDBTimeEdit: Click one of the arrows. The time is put forward or put back.
You can also place the cursor directly in the field and enter a time. The cursor
moves forward automatically so that the entry is always in the correct format.
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†

 

cxDBDateEdit:Click the arrow. A calendar opens. Choose a date by
clicking a day directly on the calendar. Click the month bar to choose
a different month.

You can page through the calendar using the arrow buttons on the
month bar, i.e. move back and forward.

Click the Today button to chose today's date.

Click the Delete button to remove a selected date.

‡

cxDBImage: Click the form component using the right mouse button.
A context menu appears:

· Cut removes the image from the form component and saves it to
the Windows Clipboard.

· Using Insert, you can paste an image from the Clipboard into a
form component of type cxDBImage.

· Using Copy, you can copy the image from the form component to
the Clipboard.

·  Using Delete, you can delete an image from the form component.
·  Using Load, you can open a dialog box for opening a file. Select an

image file and accept your selection by clicking the Open button.
·  You can save an image using Save As. The Save As window

opens first. Select a folder, enter a file name and accept your
entries by clicking the Save button.

   

ˆ cxBitstring: Click the arrow. A dialog box with check boxes opens
containing the bits to be set. Comments related to the bits are
displayed. Set the bits in the dialog box by selecting the related
check boxes. When you close the dialog box, the bits set are
displayed in a corresponding decimal or hexadecimal character
string.
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‰

          

 cxDBExComboBox: Click the arrow to open the pull-down menu. Select
an entry on the pull-down menu. The selected value is not written to the
key, instead a value saved in the Layout Designer for this menu entry is
written to the key. You cannot enter any text in the field.

Š 

   

cxDB_ComboBox: Click the arrow to open the pull-down menu. Select
an entry on the pull-down menu. You can also enter text in the field and
transfer the text to the key or to the database using Write.

 

cxDBPassword: Click the field and enter text. The text entry is hidden
using the character " * ". For data security reasons " *** " is displayed
when you leave the field with the cursor.
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3.6.3  Using templates

Using templates, you can save defined values in form fields and use these values as required.
Templates can be used to speed up writing similar data to keys.

To create and use templates, proceed as follows:

First create a template:

· Enter the required values on your form. There must be a key in the EKS Electronic-Key adapter to
enter data.

· Click Tools -> New Template. Enter a name for the new template in the Save template window and
accept your entries with OK.  

All fields that have been enabled in the Database Designer for use in template creation are saved in the
template with the values entered (cf. "Properties of the data fields").

The template is a TXT file that is saved on the EKM server.
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How to use a template:

· Click Tools -> Template list. A list is opened with the templates already added. Select the template
you want to use.

Once a template has been selected, the template icon is available on the toolbar.

· Insert the key you want to write in the EKS Electronic-Key adapter. Click the Template icon on the
toolbar or use the Template command in the Tools menu. The values saved in the template fields
appear on the form.  
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· If necessary, add data to the form and click Write to transfer the data to the key.

3.6.4  Discarding changes

If you do not want to save changes to key data, but instead want to discard the changes, click
 

 
 

the Discard icon on the toolbar or the Discard command in the Edit menu.
 

The data last transferred to the key are displayed on the form.

3.7  Database viewer

The database viewer displays the entered key data in tabular form for the components on the form.

To open the database viewer, click

 

the Database command in the Tools menu or

 

the Database icon on the toolbar.

The Database viewer window opens:

The following has to be noted:

· Only the values that the logged-on user sees on the form are displayed in the database viewer.

· The data fields that are also saved on the key have a yellow background.
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· Only values that can also be changed on the form for the user can be changed. Exceptions: Data
fields that are also saved on the key can be changed with the "Database is Master" setting (cf.
"EKM server settings").

· All columns will be displayed if the logged-on user has the Database_AllColumns right.

· The LOCKED column is displayed if one of the following rights is available:
Database_LOCKED_Visible, Database_LOCKED_Edit, Database_AllColumns.

· The LOCKED column can be changed if one of the following rights is available:
Database_LOCKED_Edit, Database_AllColumns.

3.7.1  Working with data

Lists of data records are displayed in tabular form in the EKM. Examples of these data tables are the
data views in the database viewer and in the Database Designer. The figure below shows all key data
already read into the database viewer.

 

Various functions are integrated into the tabular view:

· Searching
· Changing the position of a column
· Sorting by columns
· Grouping by columns
· Filtering data

You can mark a row by clicking the row using the mouse pointer. The functions for changing lists of data
described here are not saved when the related data view is closed.

These functions are not always integrated into every data table in their entirety.

3.7.2  Changing data in the database viewer

In the database viewer, you can change the data only if you have the corresponding rights (cf. "Database
viewer").

Data fields that are also saved on the key have a yellow background. They can be changed only with the
"Database is Master" setting (cf. "EKM server settings").
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To change data, click the data field you want to change. Overwrite the data field with the value that you
want to enter in the data field.

Once you have made all the necessary changes, leave the database viewer using OK.

Your changes will be transferred to the EKM server as soon as you leave the modified field in the
database viewer with the cursor or close the database viewer.

The database viewer includes the field-specific windows, pull-down menus and pre-formatted
fields for entering data (cf. "Data entry").
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3.7.3  Deleting database records in the database viewer

To delete data records in the database viewer, select a data record by clicking it. Then click the Delete
button.

You can also select and delete several data records:
· Using Shift + mouse button, you can select sequential data records block by block.
· Using Ctrl + mouse button, you can supplement or reduce the selection by individual data records.
· Using Ctrl + A, you can select all displayed data records. Previously filtered data records will not be

taken into account.
The selected data records will be highlighted in color and marked with a dot on the left side.
The selection of multiple data records can be canceled at any time by clicking with the mouse without
pressing the Ctrl or Shift key.

The number of selected data records, the displayed data records and the total number of data records in
the database are displayed on the right in the header.

You will receive a warning message before the deletion process takes place. Accept the message
with Yes if you want to delete the selected data records and their associated data. Your changes
will then be transferred to the EKM server.
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3.7.4  Exporting data

In the database viewer, you can export key data.

· During the CSV export, all enabled key data with the exception of key types Memo and Graphic are
exported to a CSV file.

· The first row in the export file contains the names of the database fields
· Order of the database fields:

· Database field KEYID
· Database field LOCKED
· Database fields with the key data. The sequence is the same as the order on the key. When a byte

is broken down (data type Bit or Nibble), export will take place in the sequence from Low bit to High
bit

· Remaining database fields. The sequence is the same as the order defined in the Database
Designer 

· Database fields of type StringPassword are encrypted using Secure Hash Algorithm (SHA-1). You
can find information about SHA-1 at:https://en.wikipedia.org/wiki/Secure_Hash_Algorithms

· During the SmartCard export, the serial numbers of the keys (KEYID) are converted to the card
code for the SmartCard and saved as file names for zero-byte files.

· With the CSV Export View, only the displayed key data with exception of the data types Memo and
Graphic are exported to a CSV file.

· You define the approval of the database fields for the CSV export in the CSV Export column in the
Database Designer (cf. "Designing a database").

https://en.wikipedia.org/wiki/Secure_Hash_Algorithms
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3.7.4.1  CSV export

If you want to save the key data to a CSV file, click the CSV export button in the database viewer.

The Entry of export file window opens.

Select a folder and enter a file name for the CSV file. Accept using Open. After the export, a message is
displayed:"Export completed successfully".
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3.7.4.2  SmartCard export

The SmartCard export is used to convert the key serial numbers (KEYID) to the card code for the
SmartCard. The card code is saved in the file name for a zero-byte file using the following syntax:

USERMAN_CARDxxxxxxxx.DAT
(xxxxxxxx stands for the card code).

To export the serial numbers for entered keys as SmartCard card code, click the SmartCard export
button in the database viewer.
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The Entry of export folder window opens.

Select a folder and accept your selection using OK.
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After the export, a message is displayed:

In the export folder, you will now see the files with the related card codes:

Locked keys are not saved.

The key serial number is a sixteen-digit hexadecimal number (8 bytes). For the conversion to the
card code, this number must be converted into an eight-digit hexadecimal number (4 bytes):

· The 8 byte key serial number is divided into two 4 byte values.
· The two 4 byte values are added together. Any overflow is ignored. The resulting 4 byte value is

the card code.
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3.7.4.3  CSV Export View

If you want to save a filter-restricted list of the key data in a CSV file, click the CSV Export View button
in the database viewer.

The Entry of export file window opens.

Select a folder and enter a file name for the CSV file. Accept using Open. After the export, a message is
displayed:
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3.7.5  Searching for data

Mark a field in a column with a yellow background in your table view and type the search term or the
character string you want to find. the cursor jumps to the next data record that starts with the character
string entered.

The search function is integrated into the database viewer only for the fields with a yellow background.
These fields cannot be changed in the database viewer (cf. "Changing data in the database viewer").

3.7.6  Filtering data

When you filter data, you formulate criteria that are used to select the data for the view. To activate the
filter selection, click the filter selection for a column. A list of possible selection conditions opens.
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If you have selected Custom as the criterion, the Custom Filter window opens.

Here you can link two conditions using ...
· and (both expressions are true)
· or (at least one expression is true)
. A list of operators is available for formulating the specific condition.

Once you have used a filter on a table, the expression appears on the filter status bar.
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3.7.7  Moving columns

To change the position of a column in a table, drag the column to the right or left. Two green arrows will
indicate the new position of the column. The column is moved when you release the mouse button.

3.7.8  Sorting data

To sort a table based on the content in a column, click the column. The arrow indicates whether the sort
order is ascending or descending. The existing sorting is reversed if you click the column again.

You can use several columns for the sorting by holding the Shift key when you click the column
headings. If you click a column with the Ctrl key pressed, this column is no longer used for sorting.
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3.7.9  Grouping data

Grouping the data in a table by a column means that all data records with identical fields in the related
column are combined to form a group.

To group by a column, simply drag the column to the grouping bar. You will see this data view:

Groups can be formed based on the content of several columns. The order for forming the groups can be
changed in the grouping bar.

To undo a grouping, drag the column back to the column bar.
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3.8  Importing data

You can import key data into the key database. The data to be imported must be in CSV format. The
first row in the CSV file contains the database field names.  Only fields that can be unambiguously
allocated and that match existing database fields are imported. The file to be imported must contain as
a minimum the data field KEYID with values. If database fields are missing during the import, these
fields are ZERO after the import.

To edit the CSV file, use an editor that does not change the structure of the file.

To import key data into the key database, click Import in the Tools menu. The Database import from
CSV file window opens.

Select the file to be imported and accept using Open. The import progress and, on completion of the
import, the import logger are displayed in the Database import from CSV file window.  

Using Details, you can close or open the import logger.
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If the import file contains data records that already exist in the key database, you will receive a
message:

Select ...

· Yes if you want to overwrite the key data for the KEYID displayed with the data from the import file.
· No if the key data for the KEYID displayed are not to be overwritten.
· Cancel if you want to cancel the import. The data already imported are retained.
· Yes to all if you want to overwrite the key data for all already existing KEYIDs with the data from the

import file.

Please note that a data record will be ignored during the import in the following cases:

· The data record contains invalid data. Example:
· Characters that are not allowed in the related data field
· Values that are below the minimum or above the maximum for the related data field

· The data record contains a duplicate value for a database field with the Unique restriction.

Using Tools -> Show import log, you can open the import logger for the last import. The log file is saved
on the EKM server in the ImportLog folder.

3.9  Key export/import

 

The data record of the currently displayed key can be exported in a CSV file to any folder or read from
it using the Key export or Key import function.

Key export
To export the data record, click the Key export command in the File menu.

The Key export from CSV-file window opens.

Enter a file name and save the file with Open.

Key import
To import the data record, click the Key Import command in the File menu.

The Key import from CSV-file window opens.
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Select the file to be imported and accept using Open.
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The import progress and, on completion of the import, the import logger are displayed in the Key import
from CSV-file window.  

Using Details, you can close or open the import logger.

The values read are displayed on the interface but are not applied in the database yet. The values read
are written to the key and to the database only using the Write function.

Please note that a data record will be ignored during the import in the following cases:

· The data record contains invalid data, for example:

· Characters that are not allowed in the related data field

· Values that are below the minimum or above the maximum for the related data field

· The data record contains a duplicate value for a database field with the Unique restriction

· Data for database fields of type Stringpassword will not be imported

· The Import and Export functions can be performed only when the key is inserted.

· The KeyID will not be imported.

· Data fields of type Memo and Graphic will not be exported.

· Only data approved for CSV export will be exported.

· Database fields of type StringPassword will be encrypted via Secure Hash Algorithm (SHA-1)
during export. You can find information about SHA-1
at:https://en.wikipedia.org/wiki/Secure_Hash_Algorithms

· Database fields of type StringPassword will not be imported.

https://en.wikipedia.org/wiki/Secure_Hash_Algorithms
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3.10  Design mode

To open the design mode, click Design mode in the Tools menu. The Database, Layout, Canceland
Apply icons appear on the toolbar.

In the design mode, you can:
 

· Design the database for the key data
· Design the layout for the key data forms
· Transfer all changes to the key data form and all changes to the database to the EKM server using

Apply
· Discard your changes to the key data form and to the database using Cancel
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3.10.1  Designing a database

To design a database for key data, click the Database icon in the design mode. The Database Designer
window opens.

In the Database Designer, you can:

· Insert data fields
· Delete data fields
· Change data fields

You can use the buttons in the Database Designer by:

· Clicking the buttons directly using the mouse or
· Using shortcut keys Alt+ the underlined letter

The fields with the OnKey option are saved on the key.

  

On leaving the design mode, do not forget to transfer your changes to the EKM server using Apply
(cf. "Applying your work in the EKM Designer").
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3.10.1.1  Properties of the data fields

You can design the database for the key data to suit your requirements using the EKM in the design
mode.
Exceptions are the KEYID and LOCKED data fields that are hard programmed. These fields are added
automatically when the database is created. The KEYID field can only be read. The LOCKED field can
be changed using the database viewer only if you have the Database_LOCKED_Edit or
Database_AllColumns right.

The database comprises:
 

· Fields that are written to the key during the write process.
· Data that can be retrieved centrally from the database, but not written to the key.

The amount of memory space for the data fields written to the key is limited. Please see the data
sheet on the Electronic-Key for information on the amount of memory available on the key used.

  

Data fields that are not written to the key can be added almost without limitation. However, for fast
data transfer, it should be ensured that excessively large image files are not used.
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The following data field properties must be defined when designing the database:

FieldNo Information on the order in which the fields are displayed in the database viewer.
A field can be moved up or down in the display order using Up and Down. The number is
changed automatically when a field is moved. The number is automatically incremented
when a field is added.

 OnKey
· Activated: The field data are saved on the key when data are written to the key.

· Deactivated: The field data are not saved on the key when data are written to the key
and can be seen only on the data form.

Fieldname Name of the data field
Spaces and special characters cannot be used, with the exception on the underscore
("_").

Type Data type
The data types listed below are available:

Data type Possible on key Number of
bytes

Bit X 8 bits = 1 byte

ShortInt (-128...127) X 1 byte

Byte (0...255) X 1 byte

SmallInt (-32768...32767) X 2 bytes

Word (0...65535) X 2 bytes

Integer (32 bits, signed) X 4 bytes

UInt (32 bits, unsigned) X 4 bytes

Float X 8 bytes

String X max. 116 bytes

String max. 250 bytes

StringBlankFilled: string filled with ASCII blanks
(= 20hex)

X max. 116 bytes

StringBlankFilled: string filled with ASCII blanks
(= 20hex)

max. 250 bytes

StringPassword: string hidden with "***" on the
display

max. 250 bytes

Time X 8 bytes

TimeAscii: ASCII time format
Format on key: hhmmss00

X 8 bytes

Date  X 8 bytes

DateAscii: ASCII date format
Format on key: YYYYMMDD

X 8 bytes

DateAuto: date is calculated by means of a
formula. The format on the key corresponds to
the type DateAscii.

X 8 bytes

Memo

Graphic

CRC: checksum on key X 2 bytes

BitString: integer multiple of 1 byte X max. 8 bytes

Nibble X 4 bits

Fields with the data types CRC, DateAscii or TimeAscii can only be defined as OnKey fields.
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StartByte Defines the first byte of the data field on the key
The numbering starts with " 0 "

 Length Defines the length of the data field in bytes. This length can be freely defined only for
the data types BitString and String.

 BitNo Defines the bit used in the byte

· On a field of the type Bit.

· The StartByte is defined here on a field of the type CRC.

· On fields of the type Nibble: 0 - bit no. 0-3; 4 - bit no. 4-7.

 DisplayType For the data types Nibble, Byte, Word, Bitstring and CRC, you can choose between
decimal and hexadecimal notation for display.

Template · Activated: The field is enabled for integration in a template: The value from the
allocated form field is applied when a template is created, i.e. the value is saved in
the template.

· Deactivated: The field is ignored when a template is created.

The template function cannot be activated for the fields of type Memo, Graphic, CRC
and StringPassword.

Unique
· Activated: It is not possible to save duplicate or multiple entries in the field.

Duplicates will be detected on writing.
· Deactivated: There is no Unique restriction for the field.

History
· Activated: The field is activated for the recording of changes.

· Deactivated: There is no recording of this field.
CSV export

· Yes: The field is enabled for CSV export.

· No: The field is not enabled for CSV export.

· Header: Only the field header is exported, field contents are not exported.
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Notes on the data type CRC

The CRC field forms a checksum using a configurable part of the key user data and the serial number.
The area of the user data included in the checksum is defined using the StartByte and Length fields.

The CRC field can be placed with a freely selectable StartByte on the key in a flexible manner. The
BitNo field is used for entering the StartByte.

Example:

In the example above, the checksum is formed using the key user data from byte no. 0 to byte no. 44.
The CRC field is saved in the bytes no. 46 and 47.

[ You can define only one field of type CRC per database design.

[ The field name is KEYCRC and cannot be changed.

[ An error message will be displayed if the Startbyte is within the monitored CRC area.

[ The checksum is calculated only when data are being written to the key.
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Notes on the data type BitString

The BitString field contains a defined number of bytes. The field is used in conjunction with the
cxDBBitstring form component for defining bits. You can save comments on the bits in the Database
Designer.

To save comments on the BitString field in the Database Designer, place the cursor on a BitString field
and click the BitString Editor button.
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The BitString editor opens. Enter the comments on the bits in the Description field:

Accept your entries with OK. During data entry, the comments added are displayed in a cxDBBitstring
form component related to the BitString field:
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Notes on the data type DateAuto

A field of type DateAuto contains an automatically generated date. It is calculated based on the EKM
server's system date. The new date corresponds to the current date or is a date in the future (an expiry
date, for example). The latter is defined corresponding to a difference number of days or weeks.

Immediately on insertion of the key, the new date is automatically applied in the database and, with
OnKey identification, additionally transferred to the key memory.

You can change the field calculation formula in the Database Designer:

Select the corresponding data record and open the DateAuto editor.

 

You can see the default settings here.

The following input options are available:

Operator +, -

Count decimal value

Unit days, weeks
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[ The function is executed only if the key is not locked.

[ The function is executed on a new key only if the user has the right
Initialize_DateAuto.

[ A data field of type DateAuto cannot be edited on the form or in the database viewer.

[ Only the cxDBDateEdit component can be used for display.
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3.10.1.2  Order of the bytes on the key

The data are saved on the key using the following scheme:

                                   

The little endian format is used for the order of the bytes on the key:

·  Word 2 bytes
Order on key Low byte - high byte
Example
Dec. value 258
-> hex. value

On key

 

·  Integer 4 bytes
Order on key Low word - high word
Example
Dec. value 1609060
-> hex. value

On key

 

·  CRC 2 bytes
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Order on key Low byte - high byte
Example
Dec. value 12958
-> hex. value

On key

 

·  Float 8 bytes
A floating number with eight bytes (64 bits) is divided into three fields:

The value v for the number is defined as follows:

If 0< e < 2041,  v = -1 s  * 2 (e -1023) * (1.f)

If e =0 and f<>0, v = (-1) s * 2 (-1022) * (0.f)

If e =0 and f=0, v = (-1) s * 0

If e =2047 and f=0, v = (-1) s * Inf

If e =2047 and f<>0, v is an NaN value

 

·  Date and Time 8 bytes
A floating number in accordance with IEEE 754 with eight bytes (64
bits) is divided into three fields. The  integer part corresponds to the
number of days since 30.12.1899. The fractional part defines the time.

·  DateAscii/DateAuto 8 bytes
Order on key YYYYMMDD
Example
Date May 13, 2005
On key

 

·  TimeAscii 8 bytes
Order on key HHMMss00
Example
Time 12:35:48
On key
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3.10.1.3  Inserting data fields

To insert new data fields, go to the Database Designer and click the Insert button.

Once you have entered the properties for the new data field and have selected the data type for the field,
click OK to apply the changes to the database locally. In the layout design mode, you can now bind a
form field to the new data field (cf. "Properties of EKM database components").
To transfer your changes to the EKM server, click Apply on the toolbar
(cf. "Applying your work in the EKM Designer").
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3.10.1.4  Deleting data fields

To delete data fields, select the data field to be deleted in the Database Designer and click the Delete
button.

A warning is displayed first. If you want to delete the selected data field or the selected row in the
Database Designer, accept the warning with Yes. If the deleted data field was bound to form
components, these bindings will also be deleted. A message is displayed:

 

The form fields with a red background must be re-assigned to a data field.
 

Your changes are initially applied locally.
To transfer the modified database design to the EKM server, you must click Apply on the toolbar (cf.
"Applying your work in the EKM Designer").

Note that on the deletion of a data field, all related data in the database will also be deleted!
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3.10.1.5  Changing data fields

To change data fields, click the data field in the Database Designer and overwrite the property to be
changed or select a different property.

If the modified data field was bound to form components, these bindings will be deleted. The following
message is displayed:

The form fields with a red background must be re-assigned to a data field.

Your changes are initially applied locally. To transfer the modified database design to the EKM server,
click Apply on the toolbar (cf. "Applying your work in the EKM Designer").

In some circumstances, all database entries in the modified column will be deleted if changes are
made to the data fields: This situation will occur if data type is changed
A change to the string length is not a data type change! If the string length of a data field is
shortened, characters extending beyond the new length will be truncated.
If you activate the Unique property for a field and the column contains duplicate entries in the
database, the duplicate entries will be deleted.
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3.10.2  History recording

The history recording function records changes in the key database.

[ The function is available only after activation in EKMServer.ini.

[ You define the data fields to be recorded in the History column in the Database Designer.

[ The LOCKED column is also recorded.

Ø Select the corresponding fields in which you want to record the changes.

Fields of types StringPassword, Memo and Graphic cannot be selected for the history
function.

Activating the history protocol function

The history protocol function is activated by an entry in the EKMServer.ini configuration file:

Section Configuration entry Description
[HistoryProtocol] Active=0|1 Activate function

Default: 0
Path= Path for storing the

history protocols
Default: installation path

[ When the history function is activated, the EKMServer creates the protocol file
EKM_HistoryProtocol_active.csv.

Archiving the history protocol files

The history protocol can be archived by two variants:

1. by file size

2. By date

This is also defined via the EKMServer.ini configuration file.

1. by file size

When the file size set in the EKMServer.ini configuration file is reached, the current protocol file will
be renamed to

EKM_HistoryProtocol_[year]_[month]_[day]_[hour][minute][second].csv

and a new EKM_HistoryProtocol_active.csv protocol file will be created.
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Entry in the INI file:

Section Configuration entry Description
[HistoryProtocol] FileSize [kB]= Maximum size of protocol file

Default: 5000

2. By date

Optionally or in addition to archiving by file size, archiving by date on a specific day of the month can
be selected.

Section Configuration entry Description
[HistoryProtocol] ArchiveDay= Days in the month on which a new

protocol file is to be created.

[ Permissible values 1-31, separated by semicolons.

[ If no values are specified, archiving will not take place by date.

[ If all days were to be entered, for example, archiving with date would occur every day.

Example
Archiving by date on the 1st and 8th and the 15th and 22nd days of each month

[HistoryProtocol]
Active=1
Path=C:\Euchner\EKM\HistoryProtocol
FileSize [kB]=5000
ArchiveDay=1;8;15;22

Access right for loading the protocols

In order to be able to view the history protocols, you need the corresponding access right.

Ø For this, enter the user management by clicking User in the Tools menu.

Ø Add the Button_History_Visible right to the corresponding groups.

[ The History button is shown in the main window.
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Displaying the protocols

Ø Click the History icon on the toolbar or the History command in the Tools menu.

[ The History protocol window opens.

Ø Click the Load history button.

[ The Select history protocol window opens.
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Ø Select a file and click the Open button.

[ The protocol file is transferred from the server to the client, opened and displayed in tabular form.
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Ø You can create a screenshot of the window. Click the Screenshot button and save the JPEG file in
the desired folder.

Ø You can archive the protocol file immediately using the Archive button.

Structure of the protocol file

[ The protocol file contains the following columns:

<KeyID>;<Change Date>;<Comment>;<Field Name>;<Value>;<User>

[ The type of change is specified in more detail in the Comment column:

Comment Description
Insert The key was newly added to the database
Update The value was changed
Delete The key was deleted from the database
AddHistory The "History" definition was set in the Database Designer
DeleteHistory The "History" definition was deleted in the Database Designer

[ A protocol entry will be created for each changed history column of a data record.
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3.10.3  Designing the layout

To design the layout for the key data form, click the Layout icon in the design mode. The EKM Designer
and Alignment palette windows open. These windows are beside and above the EKM main window and
can be moved as required.

Using the EKM Designer, you can design and change the key data forms by:

· Inserting form components in the key data form
· Assigning properties to form components
· Moving form components
· Aligning form components
· Deleting form components

Make sure that you enable newly added form components for viewing and editing in the user
manager once you have completed your work in the Layout Designer (cf. "Assigning rights to a
group"). On leaving the design mode, do not forget to transfer your changes to the EKM server
using Apply (cf. "Applying your work in the EKM Designer").
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3.10.3.1  An overview of the EKM Designer

You can use the Layout Designer to create and design forms for viewing and changing key data. You
can design the layout of key data forms with the aid of three windows:
 

· EKM (the form window)
· EKM Designer
· Alignment palette

�

Edit menu with the commands:
Undo, Redo, Cut, Copy, Insert
The commands in the Edit menu relate to the last action in the layout design or to selected form
components or form components saved to the Clipboard.

 

‚

 

Toolbar:
Apply quits the layout design and saves the current form temporarily and locally: The client
application continues to use the current form. When Apply is clicked, the program changes to the
first window in the design mode (cf. chap. "Design mode"). The program continues to use the
current form. To transfer the form to the EKM server and finally save it, click the Apply icon on the
toolbar again. Using Cancel, you can return to the last form design applied.

ƒ

Form area:
Area where the form components are inserted and viewed. If no forms have been created, the form
area is empty.

„

Marked form component:
In the form area, you can move and position the component as required; the appearance of the
component and other properties such as the binding to a database field can be changed in the
EKM Designer.

You can also change the size of the main window in the design mode.
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EKM Designer

�

Component bar:
Here, choose here the type of form component you want to insert on your form.

‚

Component inspector:
Displays a list with all the properties for the component currently marked. To edit a property, click
the row for the property.

ƒ

Status bar:
Displays the description for the property you are currently editing.

Alignment palette

Use the alignment palette to align several form components in the form area.
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3.10.3.2  Form components

Forms for viewing the key data can contain various form components.

The form components are divided into

· EKM database components: form fields containing data that are bound to the key database and
display key-dependent data.

· EKM standard components: form components without data binding for fixed text, images, borders,
etc.

You will find the components on the component bar in the  EKM Designer on the EKM Database and
EKM Standard tabs.
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EKM database components are:

cxDBTextEdit Text field: is used for displaying and entering text of limited length.
                 

cxDBSpinEdit Spin-edit field: displays integers. The number can be increased or
decreased using the arrow buttons.
                 

                 

cxDBTimeEdit Time-edit field: is used for displaying and for entering the time.

                 

cxDBDateEdit List box with calendar: is used for displaying and for entering the
date.
                 

 

cxDBCheckBox Check box: is used for activating and deactivating defined criteria.
                 

 

cxDBMemo Memo field: is used for displaying and entering text of unlimited
length.
                 

 

cxDBImage Graphic field: can be bound to database fields of type Graphic.
Graphic formats: JPG, JPEG.
                 

 

cxDBPassword Password field: is used for the hidden entry of passwords and is
bound to database fields of type StringPassword.
                 

cxDBBitstring Bit entry window: is used for setting bits in a defined number of
bytes. The display type in the form field and in the database viewer
is a character string in hexadecimal or decimal notation.
                 

 

cxDB_ComboBox Pull-down menu: is used for the selection of a menu entry.
With the selected menu entry, a saved value is written to the
database and possibly to the key. The form field can be bound to
database fields of the type String.
                 

cxDBExComboBox Pull-down menu: is used for the selection of a menu entry.
With the selected menu entry, a saved value is written to the
database and possibly to the key. The form field can be bound to
database fields of the type String, Nibble, Byte and Word. The
displayed value and the value of the data can be different.

 EKM standard components are:

cxGroupBox Group box: is used to visually combine several form fields in a
group; the group box features a label that can be assigned in the
component inspector. When a group box is moved, all allocated
elements are moved as one element.
                 

               

Bevel 3D blank field: is used as a fixed structuring element.

               

cxLabel Label: is used for inserting labels.

cxImage Image field: is used for inserting graphics; the following formats are
accepted: JPG, JPEG, BMP, ICO, EMF, WMF
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The list of properties for the currently marked component is displayed in the component inspector.

In the component inspector, you can access the properties for the form components and change the
properties. The component properties are displayed in alphabetical order.

All form components have general properties:

· Design of the component (border, background color, font, shading, etc.)
· Internal name for the component
· Position on the form or within a group box
· Size of the form component
· Hint for a form component
· Sequence number for navigation on the form using the Tab key

In addition to these properties, you can make other settings in the component inspector as a function of
the form component inserted:

· For EKM database components, a data field must also be selected for the components using
DataBinding -> DataField to bind the component with the database field. When a database
component is inserted, there is initially no binding to a data field.

· For the EKM database components cxDB_ComboBox and cxDBExComboBox, menu entries for
display in pull-down menus can be entered using Items. For the component cxDBExComboBox, a
value in the format String, Byte or Word is saved for the menu entry. The menu entries are added after
binding to a data field.

· Using the EKM standard components cxGroupBox and cxLabel, you can enter the label text for the
components. By default, the labels are cxGroupBox1,  cxGroupBox2 or cxLabel1, cxLabel2.

· With the EKM standard component cxImage, you can also select an image file in one of the formats 
JPG, JPEG, BMP, ICO, EMF, WMF. By default, an image file is not selected.

Note that the properties are grouped in the component inspector. If you want to view a group of
properties, click the plus sign in front of the group; if you want to hide a sub-group, click the minus
sign in front of the group.
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General properties

All components have general properties. You can change these properties in the component inspector
by clicking a property field and entering the value required.

The following list contains all the general properties and the valid entries:

�

 

Internal component name

Name Description Valid values
Name Defines the internal form field

name:
Pay attention to clear labeling: e.g.
PersonnelNumber or
cxDBTextEdit3_Name.

All characters except special characters
such as ö, ä, etc., as well as the hyphen
("-"), forward slash ("/"), backslash ("\") and
blank (" ").
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‚

 

Position of the component

Name Description Valid values
Left Defines the position of the left

edge of the component in pixels,
starting from the left edge of the
form or the group box.
 

Integer

Top Defines the position of the top
edge of the component in pixels,
starting from the top edge of the
form or the group box.

Integer

ƒ

 

Size of the component

Name Description Valid values
Height Defines the height of the

component in pixels
Integer

Width Defines the width of the component
in pixels

Integer

The height can be entered directly in the Height field only for the form components cxDBMemo,
cxDBImage, cxGroupBox, Bevel, Image. The height of the other components is automatically
adjusted to the font size set (Style -> Font -> Size).

„

 

Design of the component: Style

Name Description Valid values
Style

BorderColor Color of the component
border

Select a color from the pull-down menu

BorderStyle Style for the component
border: e.g. flat, 3D, etc.

Select a style from the pull-down menu

Color Component background color Select a color from the pull-down menu
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„

 

Design of the component: Font

Name Description Valid values
Font Font for the component content In the Font field, you can open a dialog box

where you can access the fonts installed
in the operating system. The font, its size
and color, etc., can be selected in the
dialog box.

Charset Character set that is used as the
basis for the component content.

Select a character set from the pull-down
menu

Color Font color Select a color from the pull-down menu

Height Scaling value for the font size
referred to the screen resolution

Integer

Name Font Select a font from the pull-down menu

Pitch Adjusts the character spacing
 

Size Font size Select a font size from the pull-down menu

„

 

Design of the component: Font à  Style

Name Description Valid values
Style
fsBold Bold font Activated / deactivated

fsItalic Italic font Activated / deactivated

fsStrikeOut Struck-through font Activated / deactivated

fsUnderline Underlined font Activated / deactivated

„

 

Design of the component

Name Description Valid values
Shadow Shadow: places a shadow behind

the component
Activated / deactivated

Transparent
Border

Transparent border Activated / deactivated

…

 

Navigation using the Tab key

Name Description Valid values
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TabOrder Defines the order in which the
cursor moves between the
components when the Tab key is
used for navigation

Integer

†

 

Hint for component

Name Description Valid values
Hint Hint that appears when you move

over the component with a key
inserted

All characters except special characters

ShowHint Defines whether the hint is shown Activated / deactivated

Properties of EKM database components

EKM database components have general properties as well as an allocation to a database field:

�

 

Data used for field content

Name Description Valid values
DataBinding Indicates the type of component  
DataField Indicates the data field that is used

to provide the data for the form
component

Select a database field from the pull-down
menu
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The selected form component must match the data type of the database field allocatedcf.
"Properties of data fields"). Valid bindings between form components and data types for an
allocated database field are:  

cxDBTextEdit Text field: can be bound to database fields of type
String (String, StringBlankFilled) and Number
(SmallInt, ShortInt, Byte, Nibble, Word, Integer,
UInt, Float), the KEYCRC field or the hard
programmed KEYID field.
                   

 

cxDBSpinEdit Spin-edit field: can be bound only to database
fields of type Number.
                 

 

cxDBTimeEdit Time-edit field: can be bound only to database
fields of type Time and TimeAscii.
                 

 

cxDBDateEdit Date field: can be bound only to database fields of
type Date, DateAscii and DateAuto. A list box with
calendar is available for types Date and DateAscii.
                   

cxDBCheckBox Check box: can be bound to database fields of type
Bit and to the hard programmed LOCKED field.
               

 

cxDBMemo Memo field: can be bound to database fields of
type Memo.
               

cxDBImage Graphic field: can be bound to database fields of
type Graphic. Graphic formats: JPG, JPEG.
               

cxDBPassword Password field: can be bound only to database
fields of type StringPassword.
               

cxDBBitstring Bit entry window: can be bound only to database
fields of type BitString.
               

cxDB_ComboBox Pull-down menu: can be bound only to database
fields of type String.
                     

cxDBExComboBox Pull-down menu with saved values: can be bound to
database fields of type String, Byte, Nibble and
Word. The database field selection is based on the
values that are to be saved for the entries visible on
the menu:
Example: menu entry: Level1 - saved value: 001 =>
Field with data type String
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Menu items can be saved for the combo boxes cxDB_ComboBox and cxDBExComboBox using Items:

Click the button in the Items field after you have bound the combo box to a data field.
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A field-specific string list editor opens:

String list editor: cxDB_ComboBox

 

Using the Add button, you can add new entries that are to be displayed in the pull-down menu.

To delete entries, click the row to be deleted and click the Delete button.
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String list editor: cxDBExComboBox

Add a new row per menu item using the Add button. In Description, enter the text that is to be
displayed as the menu entry in the pull-down menu. In Value, enter the value that is to be saved on
the selection of the related menu item. Ensure that the data entered under Value match the related
database field.

To delete entries, click the row to be deleted and click the Delete button.

Properties of EKM standard components

EKM standard components feature some of the basic properties and component-specific properties:

· cxGroupBox
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�

 

Labeling

Name Description Valid values
Caption Text that is used to label the

group box
All characters including the special characters

Alignment Indicates how the label is aligned
on the group box

Select an alignment from the pull-down menu

 

To insert components in a group box, the group box must first be inserted in the form, then form
components can be positioned directly in the group box. However, you can also insert the form
components into the group box using Cut and Insert. If you move a group box, the form components
contained in the group box are also moved.

· cxLabel

�

 

Labeling

Name Description Valid values
Caption Text used for the label All characters including the special characters

· Bevel

�

 

Profile

Name Description Valid values
Shape Assigns a profile to

the empty field
Select a profile from the pull-down menu
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· cxImage

�

 

Image source

Name Description
Picture The Picture-Assistent is displayed. The Picture Assistent is used to insert images into

the cxImage component or remove them from it:

You can perform the following operations in the Picture-Assistent:
   

Load Click Load... to open an image file and to insert it into the image field. You can insert image
files with the following formats: JPG, JPEG, BMP, ICO, EMF, WMF.

Save Using Save..., you can save an image that you have opened in the Picture-Assistent.
Clear Using Clear, you can remove an opened image from the Picture-Assistent. The image is then

also removed from the image field.
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3.10.3.3  Inserting form components

To insert form components, click the required component on the component bar. Then click the form
area in the position where you want to insert the form component.

The form component is inserted in the form with default properties. Change the properties of the new
form component in the component inspector. You can also move the form component again if required.
The component that was last inserted is at the front.
 

To insert components in a group box, the group box must first be inserted in the form, then form
components can be positioned directly in the group box. However, you can also insert the form
components into the group box using Cut and Insert.

Make sure that you enable newly added form components for viewing and editing in the user
manager once you have completed your work in the Layout Designer (cf. "Rights available").
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If you bind an EKM database component to an invalid database field, you will receive a message:

An invalid binding to a database field occurs if the data type for the selected database field does
not match the form field. The invalid database binding is deleted.

3.10.3.4  Selecting form components

You can see which form component is selected using the black anchor points. There are several ways
you can select a component or several components:

· Click the components using the mouse. If you keep the Shift key pressed, you can select several
components.

· Keep the Ctrl key pressed and, using the left mouse button, drag an area around the form
components you want to mark. When you release the mouse button, all components in the area are
marked.

If you want to remove a component from the selection, click the component with the Shift key pressed.
To clear a selection, click an empty part of the form area.
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3.10.3.5  Changing form components

When form components are inserted, the components have the default properties. You can change the
position and the size of the component using the mouse pointer and keyboard commands. All the
properties of a component can be changed in the component inspector:

· Select a component by clicking it. All the properties of the selected component are displayed in the
component inspector.

· Change a property by clicking the property field. When the field is clicked, it is opened for editing, i.e.
it is possible to write to the field.

· Enter the required values in this field.

If you enter invalid values for properties, the changes are not applied (cf. "General properties"ff.). A
message is displayed:
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If you bind an EKM database component to an invalid database field, you will receive the
message:

An invalid binding to a database field occurs if the data type for the selected database field does
not match the form field. The invalid database binding is deleted.

3.10.3.6  Cutting form components

Select one or several form components:

· In the Edit menu, click the Cut command
· Or press Ctrl + X

The selection is now on the Clipboard and can be inserted in a different position.

3.10.3.7  Copying form components

Select one or several form components:

· In the Edit menu, click the Copy command
· Or press Ctrl + C

The copy is now on the Clipboard and can be inserted.

3.10.3.8  Inserting a form component

You can insert form components you cut or copied to the Clipboard by:

· Clicking the Paste command in the Edit menu
· Or pressing Ctrl + V

You will see the new component on the form.

On insertion, the internal component name is changed if a component with the same name already
exists on the form.



Subject to technical modification 2093336-10-01/25Page 93/152

Manual Electronic-Key-Manager EKM

3.10.3.9  Removing form components

Select one or several form components and press the Delete key.

3.10.3.10  Moving form components

To move a component, proceed as follows:

· Select a component.
· Drag the component over the form with the mouse button pressed. You will be to see the new position

of the selected component using the black border. The coordinates for the new position are also
displayed in the hint (yellow field underneath the mouse pointer).

· Release the mouse button when you have reached the desired position.

You can also move one or several marked form components using keyboard commands:

· Select one or several form components
· Press the Ctrl + arrow keys to move the component up, down, to the right or to the left.

If you move a group box, the form components contained in the group box are also moved.

3.10.3.11  Aligning form components

Select form components and click an alignment tool in the alignment palette.

The following alignment tools are available:

     

Aligns the left edges of the form components with the component marked first

     

Aligns the vertical center line of the form components with the component marked first

             

Centers the form component horizontally in the form area or in a group box

     

Evenly spaces the form components horizontally
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Aligns the left edges of the form components with the component marked first

     

Aligns the top edges of the form components with the component marked first

     

Aligns the horizontal center line of the form component with the component marked first

     

Centers the form components vertically in the form area or in a group box

     

Evenly spaces the form components vertically

Aligns the bottom edges of the form components with the component marked first

3.10.3.12  Increasing and reducing the size of form components

You can increase or reduce the size of one or several marked form components using keyboard
commands:

· Select one or several form components.
· Press Shift + arrow keys to change the size of the component.

The height can only be set for the form components cxDBMemo, cxDBImage, cxGroupBox, Bevel,
Image. The height of the other components is automatically adjusted to the font size set (Style ->
Font -> Size).

3.10.3.13  Undoing actions on the form design

You can undo the last actions in the Layout Designer by

· Clicking the Undo command in the Edit menu
· Or pressing Ctrl + Z

3.10.3.14  Redoing actions on the form design

You can repeat the last actions in the Layout Designer by clicking the Redo command in the Edit menu.
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3.10.4  Applying your work in the EKM Designer

Once you have finished designing the database or a form for the key data, click the Apply icon on the
toolbar. EKM changes automatically from the design mode to the read and write mode. You can transfer
the form and the database design to the EKM server and save them using Apply.
 

If you have changed the form, you must assign the corresponding user rights to the newly added form
components. Otherwise it will not be possible to edit the form components and the components will also
not be shown. For this reason, when you apply a modified form the following message is displayed:

If you have changed the database design, the data in the database may be deleted in certain
circumstances (cf. "Changing data fields"). For this reason when you apply a modified database design,
the following message is displayed:

If you activate the Unique property for a field and the column contains duplicate entries in the
database, the duplicate entries will be deleted.

3.10.5  Cancelling your work in the EKM Designer

If you want to cancel your work on the database or on a form, click the Cancel icon on the toolbar.

Your changes will not be saved and will also not be transferred to the EKM server. For this reason,
when you use Cancel the following warning is displayed:
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Accept using Yes if you want to cancel your work in the design mode. EKM automatically changes from
the design mode to the read and write mode and loads the last form that was applied.
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3.11  User rights

Click the User command in the Tools menu to manage users, groups and rights. The User manager
window opens.

In the User manager window, you can:

· View groups, rights available and users
· Edit, add, remove and copy groups
· Allocate rights to the groups or remove rights from the groups
· Edit, add and remove users
· Allocate users to the groups or remove users from the groups
· Activate or deactivate the higher-level manufacturer access "EuchnerAdmin"

By default, the Administratoren group is created with the following rights and users:

Administratoren group è Rights:
Button_Database_Edit
Button_Database_Visible
Button_Designer
Button_Import
Button_ImportLog
Button_TemplateList
Button_TemplateRead
Button_TemplateWrite
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Button_Undo
Button_UserManager
Button_WriteKey

è User: ekm

After installation, change the user name and the password for the default administrator ekm. Add
new users and new groups as necessary. Add the available rights to the related groups
(cf. "Rights available").

Ensure that a user group has the right to access the user manager (= Button_UserManager) and
note the related user names and passwords to ensure that it is possible to change the access
rights and user data.

3.11.1  Managing groups

All groups already added are displayed in the left window under Groups. To display all rights held by a
group, select Rights on the View tab. All rights assigned to a group are listed underneath the group
name. To display the rights held by a group, click the plus sign in front of the group name. To hide the
rights held by a group, click the minus sign in front of the group name.  All the rights available can be
seen in the window on the right.

To display all users in a group, select Users on the View tab. All users belonging to a group are listed
underneath the group name. To display the users in a group, click the plus sign in front of the group
name. To hide the users in a group, click the minus sign in front of the group name. All the users added
can be seen in the window on the right.
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3.11.1.1  Adding groups

To add a group to the existing groups, click Add on the Group tab on the menu bar on the left.

 

Alternatively, you can click with the right mouse button to open a pop-up window with a context menu
and select Add group....

The Edit group window opens.

Enter the group name and also a description of the group as necessary.
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3.11.1.2  Editing groups

To edit a group, select a group in the window on the left under Groups by clicking it. Click Edit on the
Group tab on the menu bar on the left.

Alternatively, you can click with the right mouse button to open a pop-up window with a context menu
and select Edit group....

 

The Edit group window opens.

You can change the name and the description of the group. Accept your changes by clicking the OK
button.

If you change the name of a group, the existing allocations of rights and users to the group will be
deleted. You must again assign rights and users to the group.
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3.11.1.3  Removing groups

To remove a group, first select the User view. Now mark the related group by clicking the group. Click
Remove on the Group tab on the menu bar on the left.

Alternatively, you can click with the right mouse button to open a pop-up window with a context menu
and select Remove.

 

A window opens where you can accept your selection using Yes if you want to delete the group.
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3.11.1.4  Copying a group

When a group is copied, all the rights assigned and, optionally, all the users assigned to the original
group are copied. To copy a group, select the related group by clicking the group. Click Copy on the
Group tab on the menu bar on the left.

Alternatively, you can click with the right mouse button to open a pop-up window with a context menu
and select Copy group....

 

The Edit group window opens.

Assign a new group name and accept your entries using OK. In the next window, you can define
whether you want to copy to the group all users assigned to the existing group.

Accept the copying of the user allocations using Yes or reject the copying of the user allocations using
No. The group is copied with all rights and, as required, users and added using the new group name.
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3.11.2  Managing rights

To display all the rights available, select Rights on the View tab. All rights available are displayed in the
window on the right under Rights available.

3.11.2.1  Rights available

In the EKM, the following rights can be assigned in the user manager to the groups added:

Button_Database_Edit Permits changes to database data in the database viewer

Button_Database_Visible
 

Permits access to the database viewer

Button_Designer
 

Permits access to the Database Designer and Layout Designer with
all design features

Button_History_Visible Permits access to the history files

Button_Import Permits the import of key data in CSV format

Button_ImportLog Permits access to the log file for the last import
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Button_TemplateList Permits the selection of a template

Button_TemplateRead Permits the use of a template on a key read

Button_TemplateWrite
 

Permits the creation of a template

Button_Undo Permits changes to key data on the form to be discarded

Button_UserManager
 

Permits access to the user manager with all features for making
changes

Button_WriteKey Permits writing to the key

Database_AllColumns Permits the viewing and possibly the editing of all database columns
in the database viewer, independent of the component rights, see
below

Database_LOCKED_Edit The value of the LOCKED column can be changed in the database
viewer

Database_LOCKED_Visible The LOCKED column is displayed in the database viewer

Initialize_DateAuto Permits the writing of a DateAuto field to a new key

In addition to these rights, each form component must be enabled so that it is visible to and can be
edited by the individual groups:

· Once you have added form components in the design mode, the Komponentenname_Visible right can
be assigned for each component in the user manager. With this right, user groups can see the from
components added in the main window.

· For EKM database components, it is also possible to assign the Komponentenname_Edit right. With
this right, user groups can change the data read from the key in the form component.
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3.11.2.2  Assigning rights to a group

Select a group by clicking the group in the window on the left.

Click the double arrow pointing to the left to assign all rights available to the selected group

  

To assign a single right to the selected group, select a right by clicking it in the window on the
right. Click the single arrow pointing to the left or press Ctrl + A.
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3.11.2.3  Removing rights from a group

Select a right from a group b clicking a right in the Groups window on the left. Click the arrow that points
to the right towards the Rights available window or press Ctrl + R.

A window opens where you can accept your selection using Yes if you want to remove the right from the
group.

3.11.3  Managing users

To display all the users already added, select User on the View tab. All users already added are
displayed in the window on the right under Users.
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3.11.3.1  Adding users

To add a new user, click Add on the Users tab on the left menu bar.

Alternatively, you can click with the right mouse button to open a pop-up window with a context menu
and select Add user....

The Edit user window opens.

Complete all fields and accept your entries by clicking the OK button.

You can enable the user profile for two different types of logon:

a) Log on with password:
On logon, the user enters his/her user name and password using the keyboard.
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b) Log on with key:
On logon, the user inserts his/her key into the EKS Electronic-Key adapter.

To activate log on with key, insert the key for the user you are editing into the EKS Electronic-Key
adapter. Read the KEYID by clicking the Detect key button.

Activate the Log on with key check box.
When you save the new user data using OK, the KEYID read will be saved in the user's profile.

If both logon types - log on with password and log on with key - are deactivated, the user profile is
inactive.  

3.11.3.2  Editing users

To edit a user, select a user in the window on the right under Users by clicking the user. Click Edit on
the User tab on the menu bar on the left.

Alternatively, you can click with the right mouse button to open a pop-up window with a context menu
and select Edit user....
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The Edit user window opens.

Enter your changes and accept them by clicking the OK button.

To activate log on with key, insert the key for the user you are editing into the EKS Electronic-Key
adapter. Read the KEYID by clicking the Detect key button.

Activate the Log on with key check box. When you save the new user data using OK, the KEYID read
will be saved in the user's profile.

If both logon types - log on with password and log on with key - are deactivated, the user profile is
inactive.  

If the user name is changed, all existing allocations to groups will be deleted. The user must be
allocated to a user group again.
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3.11.3.3  Deleting users

To delete a user, select a user by clicking the user. Click Delete on the Users tab on the menu bar on
the left.

Alternatively, you can click with the right mouse button to open a pop-up window with a context menu
and select Delete users.

 

A window opens where you can accept your selection using Yes if you want to delete the user.
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3.11.3.4  Adding users to a group

Select a group by clicking the group in the window on the left. Then select a user by clicking a user in
the window on the right. Click the arrow that points to the left towards the Groups window or press Ctrl +
A.

3.11.3.5  Removing users from a group

Select a user from a group by clicking a user in the Groups window on the left. Click the arrow that
points to the right towards the Users window or press Ctrl + R.

A window opens where you can accept your selection using Yes if you want to remove the user from the
group.
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3.11.4  Manufacturer access

Active, higher-level access enables Euchner to offer controlled support in solving access problems.
Manufacturer access can be deactivated, but it cannot be deleted or edited.
To delete manufacturer access, click Deactivate.

Manufacturer access will be deactivated after agreement by the user. Successful deactivation is
displayed next to the icon and by the "Activate" button.

To reactivate manufacturer access, click Activate.

If you misplace the administrators' access data when manufacturer access is deactivated, this
cannot be corrected.
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3.11.5  Loggin on and logging off users

To log on a different user without quitting the program, click the Logon command in the File menu. In the
Logon window, enter the name and the password of the user who wants to log on.

Accept your entries with OK. The program will be re-started and the user settings loaded. If log on with
key has been activated in your user profile, you can log on by inserting your key into the EKS
Electronic-Key adapter. If your user data are incorrect, you will receive a message:

The number of consecutive logon attempts is limited to 10 to prevent spying out the passwords using
brute force attacks.
Brute force attacks attempt to determine passwords by automatically trying out common combinations.
Possible passwords are entered in quick succession until the correct password is found.
The EKM application prevents the re-entry of further user/password combinations after 10 unsuccessful
logon attempts by imposing a waiting time of 30 seconds.
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If you want to log off, click the Logoff command in the File menu.

Accept the logoff process.

The user rights are reset when you log off. The Logon window opens.
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3.11.6  Changing password

If you want to change your password, click Change password  in the File menu. In the Password change
window, enter your old password and the new password; accept your entries with OK.

If the use of secure passwords is set on the EKM server (cf.EKM server General Settings), a notice
about the password criteria is additionally displayed.
The password must consist of at least 15 characters.
The password must contain at least 1 uppercase letter, 1 lowercase letter, 1 number and 1 special
character.
Permissible special characters are ! ? @ ( ) { } [ ] \ / = ~ $ % & # * - +. , _
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3.12  EKS interface

The EKS Electronic-Key adapter is connected to the computer via a serial interface. You can select a
port for the device in the program. Select a COM port on the status bar in the main window:

If the selected port is not available or is used by another device, an error message is displayed. In this
case, select a different COM port.

3.13  Server connection

You can change the connection parameters to the EKM server by:
· Deleting the file ekm.INI in the program folder. The Connection parameters EKM-Server window

appears the next time the program is started (cf. "Installation"). Enter the new connection parameters.
· Opening the file ekm.INI and entering the new connection parameters under Server Address and

Server Port.

3.14  Automatic station

Pop-up keys resulting from key reading/writing can be suppressed for an automatic station without
control features. The Key data written pop-up window appears after automatic writing of a DateAuto field
and is automatically closed after 3 seconds.

For this purpose, edit the EKM.ini configuration file by creating the configuration entry 
Automatikstation=1 in the Settings section.

Section Configuration entry Description
[Settings] Automatikstation

=0|1
Activate function
Default: 0

3.15  Uninstalling

You can open the Uninstall EKM uninstall routine using the Windows Start menu.
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4  EKM server

4.1  Installation

You can use the EKM server as a service or as an application. The installation and removal of the server
vary depending on how the server is used.

4.1.1  Installation as an application

To install the EKM server, add a new folder for the server and copy the file EKMServer.exe to the folder.

Start the application by double-clicking the file EKMServer.exe. The EKM server starts automatically.
You will see the EKM server icon on the Windows taskbar.

Check the configuration of the EKM server (cf. "Configuration of the server").
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4.1.2  Installation as service

To install the EKM server, create a folder for the server and copy the files EKMServer.exe and
EKMAdmin.exe to the folder.

Start EKMAdmin by double-clicking EKMAdmin.exe.
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The administration tool appears. Install the service by clicking Install Service in the administration tool.
On successful installation the following message is displayed:

You will find the EKM server as a service in the operating system in Services. The service starts
automatically when the computer is re-started.
Before starting the service, check the EKM server configuration (cf. "Configuration of the server").

4.1.3  EKM files

All files used by EKM are saved in the EKM installation folder.

When EKM is installed on Windows 7, Windows Server 2008 or newer and the installation path is
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"C:\Program Files\<EKM>" or "C:\Program Files (x86)\<EKM>", the operating system redirects
user-specific files to the VirtualStore. The VirtualStore is located under:
"C:\Users\<User>\AppData\Local\VirtualStore\Program Files\<EKM>".

4.2  Starting the EKM server

Depending on the type of installation, the EKM server is started in different ways.

4.2.1  Starting the EKM server as application

If you installed the EKM server as an application, double-click the EKM server icon on the Windows
taskbar. The configuration interface opens There, you can click Start Server at the upper right to start
the server. If Stop Server is displayed at the upper right, the server has already been started.
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4.2.2  Starting the EKM server as service

If you have installed the EKM server as a service, start the EKMAdmin.exe file in the EKM installation
folder. The configuration interface opens There, you can click Start Service to start the service. If Stop
Service is displayed at the upper right, the service has already been started.
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4.3  Stopping the EKM server

Depending on the type of installation, the EKM server is stopped in different ways.

4.3.1  Stopping the EKM server as application

If you installed the EKM server as an application, double-click the EKM server icon on the Windows
taskbar. The configuration interface opens There, you can click Stop Server at the upper right to stop
the server. If only Start Server is displayed at the upper right, the server has already been stopped or
was not started.
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4.3.2  Stopping the EKM server as service

If you have installed the EKM server as a service, start the EKMAdmin.exe file in the EKM installation
folder. The configuration interface opens There, you can click Stop Service at the upper right to stop the
service. If only Start Service is displayed at the upper right, the service has already been stopped or was
not started.
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4.4  Uninstalling

You can use the EKM server as a service or as an application. The installation and removal of the server
vary depending on how the EKM server is used.

4.4.1  Uninstalling the EKM server as application

If you installed the EKM server as an application and started the server, you only need to quit the
application to uninstall the EKM server. Click the EKM server icon on the Window taskbar using the
right mouse button.

The EKM server context menu opens. Click the Close command.

The EKM server icon disappears from the taskbar.

If you no longer want to use the EKM server, you can delete the program folder containing the file
EKMServer.exe. Please note that the data saved on the EKM server will also be deleted during
this process.
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4.4.2  Uninstalling the EKM server as service

To uninstall the EKM server service, open the EKM installation folder. Start EKMAdmin by double-
clicking EKMAdmin.exe.

The administration tool appears. Uninstall the service by clicking Uninstall Service in the administration
tool. On a successful uninstall the following message is displayed:

If you no longer want to use the EKM server, you can delete the program folder containing the
files EKMServer.exe and EKMAdmin.exe. Please note that the data saved on the EKM server will
also be deleted during this process.
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4.5  Configuration

The EKM server is configured using the configuration interface. Using the configuration interface, you
can

· Configure the server
· Display log entries
· Make export settings

4.5.1  Opening the configuration interface

Depending on the type of installation, you can open the configuration interface in different ways.
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4.5.1.1  Configuration interface of the application

You open the configuration interface by ...

· Double-clicking the EKM server icon on the Windows taskbar.
· Opening the server context menu via the EKM server icon on the Windows taskbar using the right

mouse button and clicking the Properties menu item there.

The configuration interface opens.

Before making changes to the configuration, stop the EKM server by clicking the Stop Server
button.



Subject to technical modification 2093336-10-01/25Page 129/152

Manual Electronic-Key-Manager EKM

4.5.1.2  Configuration interface of the service

If you have installed the EKM server as a service, start the EKMAdmin.exe file in the EKM installation
folder. The configuration interface opens Before making changes to the configuration, stop the EKM
server by clicking the Stop Service button.
Except for the "Install service" button, the configuration interface of the service does not differ from the
configuration interface of the application. In the interest of better legibility of the manual, only images of
the configuration interface of the application will be shown in the following sub-chapters.

4.5.2  Configuration of the server

To configure the EKM server, you must first stop the server. The configuration options are available only
after the server has been stopped:

You can see the default settings in the figure. As a rule the options set on installation do not need to be
changed. If necessary, the log function can be switched off to improve performance.

The server must be stopped to be able to make changes to the configuration. For this purpose,
click the Stop Server button.
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The configuration interface is subdivided into three tabs: Settings, Logging and Export. You can change
between the tabs by clicking the button with the corresponding name in the lower area.
You can find further information about the content and options on the tabs in the following sub-
chaptersSettings,LoggingandExport.

4.5.3  Settings

The basic settings for the EKM server can be made on the Settings tab. Always stop the server before
changing any settings, and do not forget to save the changes before starting the server.
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4.5.3.1  Server Settings

The EKM server communicates with its clients via HTTP. A binding must be defined for the EKM server
to notify it about the address and port it must use to listen for requests. If the defined binding was not
created previously, the EKM server will create the binding when the server is started and remove it again
when the server is stopped. If you do not wish to use a binding other than the default binding (http://
+:9222/EKM/), you do not have to do anything. Please note that the default binding does not use
encryption.
If you wish to use a different port, set up encryption or create the binding in advance, follow the
instructions:
It can be useful in some cases to create the binding in advance. When creating the binding, please
make sure that the port and the HTTP address path are not already being used by another program.
More information about bindings is available in thedocumentation fromMicrosoft.
To create the binding, click the Edit Binding button in the Server Settings section of the configuration
interface. A new window opens in which you can select the created binding, create new bindings and
configure the SSL settings for the binding:

Create a new binding by clicking the Add Reservation button. A new window opens. Enter the required
binding and check Everyone in Granted to Accounts. If you wish to use encryption for the data traffic,
your binding must begin with https://. Otherwise your binding must begin with http://. Click OK to create
your binding.
Then select the binding you just created by selecting it in the list on the left side and then clicking the
Choose Selected button. You can use Remove Selected to delete a selected binding from the list
permanently.

Do not delete any bindings that you did not create yourself. These bindings are often required for
the proper function of the operating system and its services.

https://learn.microsoft.com/en-us/windows/win32/http/urlprefix-strings
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Encryption

You must use https binding to encrypt the data traffic between the EKM client and the EKM server. This
binding requires a valid certificate including the associated private key. In the SSL Bindings section, you
can select the certificate to be used for a defined port. Operating the EKM server without data traffic
encryption is not recommended and does not comply with the current legal requirements for the
transmission of personal data.
Open the SSL Bindings tab to assign a certificate to a port.

If the port of the previously selected binding already has an assigned certificate, you can see it in the list
on the left side. Select the entry and check whether the correct certificate is used. You can do this
using the information displayed on the right side or using the View Certificate button.
If the binding's port does not appear in the list yet, create a new SSL binding by clicking the Add
Binding button.

In the following dialog box, enter the IP address of the network adapter to which the certificate is to be
bound. With the IP address "0.0.0.0", the certificate is bound to all existing network adapters. Then
enter your binding's port. Do not change the app ID. Subsequently click Select Certificate and select a
suitable certificate in the displayed Windows Management Console for computer certificates.
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Accept selection of the certificate with OK and then create the new SSL binding by clicking Okay. You
can then close binding configuration. Click the Close button for this purpose.
To save the current configuration progress, click the Save button at the lower right in the configuration
interface. If you are asked whether you wish to overwrite the configuration, confirm the prompt.

4.5.3.2  General Settings

You can define general server settings in this section.
· Password Quality:

Activate this check mark to activate inspection of the password quality requirements. If inspection of
the password quality by the EKM server is activated, all users will be prompted to adapt the password
used to the quality requirements at the next logon. The password must consist of at least 15
characters. The password must contain at least 1 uppercase letter, 1 lowercase letter, 1 number and
1 special character. Permissible special characters are : ! ? @ ( ) { } [ ] \ / = ~ $ % & # * - +. , _

· Data Synchronization:
With a new option, the direction of data synchronization between key and database of the "OnKey"
fields on the key becomes adjustable.
o Key is Master: Select this option if the values in the database are to be overwritten with the values

on the key when a key is read.
o Database is Master: Select this option if the values on the key are to be overwritten with the values

in the database when a key is read. Before the write command is started, the user's agreement is
requested using a dialog box on the EKM application. To avoid write errors, the key must not be
removed during the write process. Changing the data in the "OnKey" fields in the database viewer is
possible in this setting.

· Days to keep Backups:
Number of days after which an automatically created database backup will be deleted. You will find
further information about the database backup in the chapterData backup.

4.5.3.3  Logging Settings

You can configure server logging in this section.
· Active: Check to activate logging.
· Log File Directory: Relative or absolute path to a folder for saving the log files. Click the button on the

right with the three dots (...) to open the directory selection dialog.
· Days to keep Files: The number of days after which a log file will be deleted.

4.5.3.4  History Settings

You can define the Key History settings in this section. The Key History documents the changes of
EKM key values performed using the EKM client.
· Active: Check here to activate the Key History.
· History Directory: Relative or absolute path to a folder for saving the History files. Click the button on

the right with the three dots (...) to open the directory selection dialog.
· Max. Filesize [KB]: The maximum file size of a History file. A new History will be created if this file

size is exceeded.
· Days to keep Files: The number of days after which a history file will be deleted.

4.5.3.5  REST Api

You can configure the REST Api in this section. You will find further information about the REST Api in
the REST Api sub-chapter.
· REST Api Enabled: Check here if you want to activate the REST Api.
· Users.xml file: path to the Users.xml file for the REST Api. Click the button on the right with the three

dots (...) to open the file selection dialog.
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4.5.4  Logging

You can access the Logging tab by clicking Logging in the lower area of the configuration interface.
The Logging tab shows a live depiction of the server's current log file content.

4.5.4.1  Configuration

EKM server logging can be configured on the Settings tab. You will find further information in the sub-
chapterSettings.

4.5.4.2  Key-Log

In addition to the server's log entries, the insertion and removal of a key is logged on a client. Date, time
and KEYID are also logged with these Key-In / Key-Out events. The EKM server distinguishes between
two events:
· Key-In: A key is inserted into the EKS Electronic-Key adapter.
· Key-Out: A key is removed from the EKS Electronic-Key adapter.
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4.5.5  Export

In the configuration interface, click the Export tab to configure the CSV or SmartCard export functions.
Always stop the server before changing any settings, and do not forget to save the changes before
starting the server.

The server must be stopped to be able to make changes to the configuration. For this purpose,
click the Stop Server button.

�

CSV export

The CSV export is performed automatically after every change to the key data, and it creates a
CSV file containing the key data. During the CSV export, all configured key data with the
exception of data types Memo and Graphic are exported to a CSV file.

You can configure the CSV export with the following options in the CSV export section on the
Export tab in the configuration interface:
· Enabled: You can activate the CSV export by checking Enabled.
· CSV file path: The file path where the CSV file is saved. To change the path, click the button

on the right with the three dots (...).
· External Program: Check here to start a different program after the CSV export.
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· Ext. Program Path: Indicates the file path of the external program. To change the path, click
the button on the right with the three dots (...).

A CSV file with the following properties will be written during the CSV export:
· Encoding: Windows-1252 (ANSI)
· Separator: ;
· Quotes: "
· Newline: CRLF

Fields in the CSV file can be enclosed in quotes if necessary. Quotes in the field are identified
using a quote character. Separators or Newline sequences in a field enclosed in quotes must be
ignored during reading. For further information, see RFC 4180.

The first row in the export file contains the names of the database fields. The following rows each
contain one key per row. The fields are arranged as follows:
· Database field KEYID
· Database field LOCKED
· Database fields with the key data. The sequence is the same as the order on the key. When

a byte (data type Bit or Nibble) is broken down, export will take place in the sequence from
Low bit to High bit.

· Remaining database fields. The sequence is the same as the order defined in the Database
Designer.

Please note that only fields that have the value yes or Header in the Database Designer during
CSV export will be exported. Fields with the value "no" will not be exported. Fields that have the
value "Header" will be exported as empty columns without content (cf. "Designing a database").
Database fields of type StringPassword are saved as hashes using Secure Hash Algorithm (SHA-
1). For further information about SHA-1, see RFC 3174.

If Launch External Program after Export is activated, the specified external program will be
started after export. This program can then process the CSV file. A further export can be
triggered only if the temporary CSV file has been deleted by the external program.
A possible example for an external program is the following: An application is used that encrypts
the exported key data. When opened, the application accesses the CSV file, processes the key
data and outputs the encrypted data in another file. Once the process is complete, the CSV file
is deleted by the application.

‚

SmartCard-Export:

The SmartCard export creates a SmartCard file for each active (not locked) key in the database.
These files have no content (size: 0 byte), but they do have a systematic name containing the card
code. The card code is calculated from the keys' serial number (KEYID).

You can configure the SmartCard export with the following options in the SmartCard export section
on the Export tab in the configuration interface:
· Enabled: You can activate the SmartCard export by checking Enabled.
· Directory Path:  Relative or absolute path to a folder for saving the SmartCard files. Click the

button on the right with the three dots (...) to open the directory selection dialog.

The file names have the following syntax (xxxxxxxx stands for the card code):
USERMAN_CARDxxxxxxxx.DAT

The key serial number is a sixteen-digit hexadecimal number (8 bytes). For the conversion to
the card code, this number must be converted into an eight-digit hexadecimal number (4
bytes):
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· The 8 byte key serial number is divided into two 4 byte values.
· The two 4 byte values are added together. Any overflow is ignored. The resulting 4 byte

value is the card code.

Locked keys are not saved or deleted.

When the server is running, data are synchronized automatically between the EKM database and
the SmartCard export directory every hour. SmartCard export is also initiated when the following
events occur:

· Create key: corresponding SmartCard file is created
· Delete key: corresponding SmartCard file is deleted
· Disable key: corresponding SmartCard file is deleted
· Enable key: corresponding SmartCard file is created

A SmartCard export will not take place if the data saved on the key are changed or if they are
assigned to the key via the database.
If the server is stopped or if the export is deactivated, the SmartCard files will remain unchanged in
the SmartCard export folder.
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4.6  Update function

Electronic-Key-Manager EKM features an automatic update function for the EKM client. For this
purpose the folder "ClientVersion" is automatically added to the program path for the EKM server on
program start. You can save the current version of the EKM client in this folder.
If a new version of the EKM client is available, copy the file EKM.EXE to the EKM server's
"ClientVersion" folder. To apply the new version, stop and start the EKM server. The EKM clients will
receive the new version on the next logon. On the application of the new version, the EKM client is
automatically quit and re-started.

4.7  Data backup

All data that EKM clients edit are saved on the server in ServerDatabase in the EKM server program
folder:

The ServerDatabase folder contains the following sub-folders and files:

� Backup folder

‚ Layout

ƒ Database files

The database contains all key data and all user data
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The layout for the key data form is saved separately in the file ekmDesign.dfm. When changes are
made in the design mode, a backup copy of the last valid design is saved as a ZIP file in the backup
folder: The ZIP files are named according to the current date and time. Depending on the changes made
in the design mode, database files and/or the file ekmDesign.dfm are stored as a backup.

Back up the folder ServerDatabase at regular intervals.  

4.8  User-specific logo

The logo displayed in the EKM client can be replaced with a user-specific logo. Save the required logo
as a file with the name "CompanyLogo.bmp" in Windows Bitmap format. Then copy the file to the sub-
folder "ServerDatabase" in the EKM server application path. All EKM clients will receive the user-
specific logo the next time they log on. The logo image size is 150 (wide) x 40 (high) pixels.

4.9  REST Api

Using the REST Api, you can grant other programs restricted access to the key data of the EKM server.
You can find instructions on configuring the REST Api in the chapterSettings.

The following operations can be performed:
· Determining the key data structure
· Reading key data
· Changing key data (restrictions apply)
· Deleting key data

New keys cannot be created or added using the REST Api. OnKey fields and the KEYID cannot be
changed.

4.9.1  Access restriction

Access is restricted to predefined users who authenticate themselves using user name and password in
the requests. The users are specified in the users.xml file. An example of the content of a users.xml file
looks like this:

<rest-api-users>

 <user>

   <name>exampleUser1</name>

   <password>0edf3ed0.....</password>

   <role>0</role>

 </user>

 <user>

   <name>exampleUser2</name>

   <password>0edf3ed0.....</password>

   <role>2</role>

 </user>

</rest-api-users>

Each user entry in the XML file has three values:
· <name>: The user name, required for authentication
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· <password>: The user's password as SHA-512 hash (represented as a hexadecimal string) according
to RFC 6234. In the example, the hashes are shortened to improve legibility.

· <role>: The user's role. The role can have the value 0, 1 or 2.

The following user roles are possible that can be assigned to a user of the REST Api in the users.xml
file:
· 0: Users with role 0 can perform the SQL commands SELECT and STRUCT. They thereby have only

read access.
· 1: Users with role 1 can perform the SQL commands SELECT, STRUCT and UPDATE.
· 2: Users with role 2 can perform the SQL commands SELECT, STRUCT, UPDATE and DELETE.

4.9.2  REST request

REST requests are sent to the EKM server as HTTP requests. Depending on the configured binding, the
request URI consists of:

URI = BINDING + "/db/keys"

Example: The default binding is http://+:9222/EKM/. If the computer's host name is ekm.server.local,
the following URI results for the REST request:

http://ekm.server.local:9222/EKM/db/keys

The HTTP method for the request is POST. The body contains JSON (ISO/IEC 21778:2017, ECMA-404)
data with the following structure:

{

   "authentication": {

       "user": "exampleUser1",

       "password": "my secret password"

   },

   "request": {

       "SQLQuery": "SELECT * FROM keys"

   }

}

The authentication object contains a user field containing the user name for the request and a password
field displaying the user's password in plain text.
The request object contains a SQLQuery field containing the SQL query of the request. The EKM server
performs the SQL query and returns a corresponding reply.

The SQLQuery supports only a subset of the SQL standard. The following SQL statements are
supported.
· SELECT
· UPDATE
· DELETE

The following SQL operators and expressions are supported.
· WHERE
· AND
· OR
· <
· >
· =
· NOT
· LIKE
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· NOW
· ORDER BY
· ASC
· DESC

Queries can be performed only on the keys table. Subqueries (nested queries) are not supported. Users
must have the corresponding role for the queries performed, otherwise an error will be returned. In
addition to the SQL standard, the STRUCT request is supported. This returns the structure of the keys
table. A Struct query consists only of the STRUCT statement.

The server's reply is always a JSON object that, depending on the request, contains only a status or
contains data in addition to the status.

4.9.3  Status codes

{

   "status": {

       "code": 200,

       "description": "Okay"

   }

}

Each reply object contains the status field. The status object has a code field and a description field.
The following HTTP status codes are possible:
· 200: Okay
· 202: Accepted
· 400: Bad Request
· 401: Unauthorized
· 403: Forbidden
· 404: Not Found
· 405: Method not allowed
· 406: Not acceptable
· 429: Too Many Requests
· 500: Internal Server Error

For further information, seeRFC 9110 15. Status codes.

4.9.4  Struct request

On a successful request with the SQL query STRUCT, the result can appear as follows:

{

   "status": {

       "code": 200,

       "description": "Okay"

   },

   "data": [

       {

           "name": "KEYID",

           "onKey": true,

           "unique": true,

           "length": 16,
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           "type": "String"

       },

       {

           "name": "LOCKED",

           "onKey": false,

           "type": "Bit",

           "unique": false

       },

       {

           "name": "HasPassedSafetyCheck",

           "onKey": true,

           "type": "Bit",

           "unique": false

       },

       {

           "name": "MyShortIntColumn",

           "onKey": false,

           "type": "ShortInt",

           "unique": false

       }

   ]

}

In addition to the status field, the object returned also has a data field. This consists of an array
containing the field definitions of the keys table. Each field definition is an object with the following fields:
· name: Name of the field. JSON data type: String
· onKey: Indicates whether the field values are stored on the key. Data type: Boolean
· type: Indicates the field's data type. Possible values are "Bit", "ShortInt", "Byte", "SmallInt", "Word",

"Integer", "UInt", "Float", "String", "StringBlankFilled", "StringPassword", "BitString", "Time",
"TimeAscii", "Date", "DateAscii", "DateAuto", "Nibble", "CRC", "Memo" and "Graphic". JSON data
type: String

· unique: Indicates whether the field's values must be unique. JSON data type: Boolean
· length: This field is present only if the field's data type is String or BitString. Indicates the field's

length. JSON data type: Integer

4.9.5  Select request

On a successful request with a SELECT SQL query, the result can appear as follows:

{

   "status": {

       "code": 200,

       "description": "Okay"

   },

   "data": [

       {

           "LOCKED": false,

           "MyBooleanColumn": false,

           "ByteColumn": 255,
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           "KEYID": "00D46217D9001032",

           "DB_Memo": "Text Information",

           "Key_Word": 65535,

           "DB_BitString": 15

       }

   ]

}

In addition to the status field, the object returned also has a data field. This consists of an array
containing the returned data records of the keys. Each key data record is a JSON object containing the
fields selected by the SQL query. The field names correspond to the names of the defined columns. The
JSON fields have different JSON data types depending on the key data:
· Empty field (not to be confused with the empty string or 0): zero
· ShortInt, Byte, SmallInt, Integer, Word, Nibble, CRC, UInt, BitString: Number (Integer)
· Bit: Boolean
· String, StringBlank, StringPassword, Memo: String
· Float: Number (Float)
· Date, DateAuto, DateAscii: String (format is yyyy-mm-dd)
· Time, TimeAscii: String (format is hh:mm:ss.zzz)
· Graphic: String (image bytes as Base64 string, see RFC 4648)

4.9.6  Examples

Examples of possible requests and the REST Api replies are shown below. The requests and replies
can differ depending on the key table structure.

4.9.6.1  Reading all Electronic-Keys

Request:

{

   "authentication": {

       "user": "admin",

       "password": "secret"

   },

   "request": {

       "SQLQuery": "SELECT * FROM keys"

   }

}

Reply:

{

   "data": [

       {

           "KEYID": "0000111122223333",

           "LOCKED": false,

           "First name": "Fabian",

           "Last name": "Keller",

           "Worker_ID": "B87",
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           "Protection level": 3

       },

       {

           "KEYID": "0000111122223356",

           "LOCKED": false,

           "First name": "Theodor",

           "Last name": "Dach",

           "Worker_ID": "A19",

           "Protection level": 1

       },

       {

           "KEYID": "1111222233334444",

           "LOCKED": false,

           "First name": "Max",

           "Last name": "Mustermann",

           "Worker_ID": "A19",

           "Protection level": 4

       }

   ],

   "status": {

       "code": "200",

       "description": "Okay"

   }

}

4.9.6.2  Reading selected Electronic-Keys

Request:

{

   "authentication": {

       "user": "admin",

       "password": "secret"

   },

   "request": {

       "SQLQuery": "SELECT * FROM keys WHERE Schutzstufe = 4"

   }

}

Reply:

{

   "data": [

       {

           "KEYID": "1111222233334444",

           "LOCKED": false,

           "First name": "Max",

           "Last name": "Mustermann",
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           "Worker_ID": "A19",

           "Protection level": 4

       }

   ],

   "status": {

       "code": "200",

       "description": "Okay"

   }

}

4.9.6.3  Reading specific columns

Request:

{

   "authentication": {

       "user": "admin",

       "password": "secret"

   },

   "request": {

       "SQLQuery": "SELECT KEYID, First name, Last name FROM keys"

   }

}

Reply:

{

   "data": [

       {

           "KEYID": "0000111122223333",

           "First name": "Fabian",

           "Last name": "Keller"

       },

       {

           "KEYID": "0000111122223356",

           "First name": "Theodor",

           "Last name": "Dach"

       },

       {

           "KEYID": "1111222233334444",

           "First name": "Max",

           "Last name": "Mustermann"

       }

   ],

   "status": {

       "code": "200",

       "description": "Okay"

   }
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}

4.9.6.4  Changing data

Request:

{

   "authentication": {

       "user": "admin",

       "password": "secret"

   },

   "request": {

       "SQLQuery": "UPDATE keys SET Last name = 'Muster' WHERE
KEYID='1111222233334444'"

   }

}

Reply:

{

   "status": {

       "code": 202,

       "description": "Accepted"

   }

}

4.9.6.5  Deleting data

Request:

{

   "authentication": {

       "user": "admin",

       "password": "secret"

   },

   "request": {

       "SQLQuery": "DELETE FROM keys WHERE KEYID='0000111122223333'"

   }

}

Reply:

{

   "status": {

       "code": 202,

       "description": "Accepted"

   }

}
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4.9.6.6  Wrong authentication

Request:

{

   "authentication": {

       "user": "admin",

       "password": "wrongpassword"

   },

   "request": {

       "SQLQuery": "STRUCT"

   }

}

Reply:

{

   "status": {

       "code": 401,

       "description": "Unauthorized"

   }

}

4.9.6.7  Missing authorization

Request:

{

   "authentication": {

       "user": "userWithRole2",

       "password": "secret"

   },

   "request": {

       "SQLQuery": "DELETE FROM keys WHERE KEYID='0000111122223333'"

   }

}

Reply:

{

   "status": {

       "code": 403,

       "description": "Forbidden"

   }

}
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5  EKM Admin

EKM Admin is used for configuration of the EKM server if this was installed as a service. The interface
and function correspond to the function of the EKM server. In addition to the interface of the EKM server,
Admin displays the Install Service / Uninstall Service button with which the EKM server can be
installed/uninstalled as a service.
EkmAdmin.exe and EKMServer.exe must both be located in the program folder. You will find further
information about configuration in the sub-chapterConfiguration.
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