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1  Introduction

1.1  What is the EKM

The Electronic-Key-Manager EKM is a comprehensive software solution for programming and managing
the Electronic-Key-System EKS. The EKS provides access control on PCs and control units in an
industrial environment. In comparison to the issue of a password, considerably more responsibility is
assigned to the owner of an Electronic-Key. This provides protection against unauthorized access to
operating and visualization systems.
 
In principle EKS comprises two components: 
an Electronic-Key and the matching Electronic-Key adapter. It is an inductive Ident system. A memory
chip and an antenna are built into the Electronic-Key (transponder). The Electronic-Key adapter is a
read/write system with integrated evaluation unit and interface. 
 

EKM supplements the EKS with a flexible, customizable software environment.
 

Your advantages:

Electronic-Key programming
Database-based management of the Electronic-Keys
Display of data and writing of data to the keys using a flexible user interface
Expansion of the key memory areas with customizable database fields
Role-based management of access rights
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1.2  System overview

EKM is based on a client/server architecture comprising the EKM client and the EKM server.

The Database Designer and Layout Designer are intelligent tools that enable you to design the
database and user interface and to customize them without the need for specialist knowledge. The role-
based user management makes it possible to simply and rapidly structure users into groups and to
assign user rights. This aspect includes comprehensive program functions as well as the clarity and
editing features of specific form components.

When a key is read, the data read are displayed on the customizable key data form. During this
process the data from the key are interpreted and formatted using the format from the form. The data
can be changed on the form and transferred to the key using the write function. In parallel to writing to
the key, the key data are transferred to the EKM server where they are saved centrally in the key
database. You can access the key database and maintain the data for the Electronic-Key with the aid
of a database viewer.
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1.3  System requirements

EKM has the following system requirements (full version): 

Commercial PC from Pentium II
Operating system Windows XP / Server 2003 / Server 2008 32 Bit / Server 2008 64 Bit / 
Windows 7 32 Bit / Windows 7 64 Bit / Server 2008 R2
Internet-Explorer from version 5.0
A network card with TCP/IP protocol installed
A serial or USB interface

To read and write Electronic-Keys you will need an EKS Electronic-Key adapter with serial or with USB
interface.
EKM can be operated with Electronic-Keys read/write and Electronic-Keys read-only.

1.4  Demo version

The demo version of the EKM allows you to test the full version of the product so that you can see for
yourself the advantages. 

At a glance:

Functionality of the full version
Only local EKM client possible
Limited to 10 weeks runtime
Data, database and forms prepared can continue to be used with the full version

The demo version has the complete functionality of the full version of the EKM. The runtime of this
version is limited to 10 weeks. The demo version has no network support: client and server must be
installed on one computer. All data prepared with the demo version can continue to be used with the full
version without problems.

The demo version is only allowed to be used for demonstration, test and evaluation purposes.
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1.5  Light version

The Light version is a functionally limited version based on the single-user version.

There are the following limitations

a) in the client:

No access onto the database viewer
No template functions
Export / Import for single keys only
Only local EKM client possible

b) in the server:

No access onto the server. No display of the icon in the tray bar. The server gets automatically
started by the client.

There is an upgrade possibility to the single-user or full version. New data are stored in the
database and become visible after activation.

The TCP/IP protocol is also required for the EKM light version.

1.6  Single-user version

The EKM single-user version enables you to use the full functionality of EKM on a local PC drive.

At a glance:

Functionality of the full version
The client automatically starts the EKM server 
Only local EKM client possible
Data, database and forms prepared can continue to be used with the full version

The single-user version has no network support: client and server must be installed on one computer.
All data prepared with the single-user version can continue to be used with the full version without
problems.

The TCP/IP protocol is also required for the EKM single-user version.

1.7  Full version

The EKM full version has a client/server architecture and full network support.

At a glance:

Includes all documented functions
Client/server architecture
Network support 
System requirements cf. "System requirements"
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1.8  Explanation of symbols

The following symbols are used in this manual to identify important instructions and useful information:

Tip!
This symbol marks tips and tricks.

Information!
This symbol marks general important notes.

Warning!
This symbol marks instructions that you should perform to avoid the risk of the loss of data. This
symbol therefore appears next to notes that you must observe to be able to use the functionality of
EKM. 
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2  Getting started

The "Getting started" chapter provides examples of the necessary steps that you must take the first
time you use EKM before you read or write Electronic-Keys. During this process you will obtain an
overview of the basic functions of the program.

2.1  Starting program

Start EKM via the entry in the Windows start menu. On the full version, the EKM server has to be
started first. Alternatively EKM can be started by double-clicking the file EKM.exe respectively
EKMServer.exe. Enter the connection parameters for the EKM server. Logon as the default user ekm
using the password ekm. The main EKM window opens with an empty form area.
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2.2  Changing default user

Open the user manager using Tools -> User. Change the name and password for the default user by
choosing User on the View tab, marking the user ekm and then clicking Edit on the User tab. The Edit
user window opens where you can enter the new user data. Assign the user to the Administrators user
group. 

As necessary add new user groups and users and assign the appropriate rights to the individual user
groups.

When adding rights, ensure that the Administrators group has all available rights (cf. "Rights
available"). Leave the user manager with Close and logon as a user with administrator rights using
File -> Logon.
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2.3  Administring a database

Use Tools -> Design mode to change to the design mode. Now click the Database button. The
Database Designer opens.

Add all the required data fields to the database. During this process define the properties of the data
field: 

OnKey (data are written to the key) 
Fieldname 
Type
StartByte
Length (if the data field is written to the key)
BitNo (if the data type is Bit)
DisplayType (for the data types Byte, Word, CRC: Dez for decimal notation and Hex for
hexadecimal notation).
Unique (select to prevent duplicate entries)
Template (select to enable field for templates)

The order of the fields displayed in the Database viewer is indicated in the FieldNo field. The data fields
KEYID (data type String) and LOCKED (data type Bit) are hard programmed and are not visible in the
Database Designer. Accept your entries with OK. The Database Designer is then closed.

2.4  Designing user interface and selecting data source

Now click the Layout button. The EKM Designer opens. The component bar on the EKM Database and
EKM Standard tabs in the EKM Designer contains various form components:
 

EKM database components: form fields that are bound to the key database and display the data read
when the keys are edited.
EKM standard components: fixed form components such as form field names, images, etc.

To insert form components in the key data form, click the component you require on the component
bar. Then click the form in the position where you want to insert the form component. 
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You can change components added:
 

In the component inspector you can enter or select the properties
You can move a marked component using the mouse. 
The size of a component can be reduced or increased using Shift + left/right arrow key.
A component can be moved using Ctrl + left/right arrow key. 

 

Design the form and enter the data source for all EKM database components by marking a component
and selecting a database field in the component inspector using DataBinding -> DataField.

Ensure the database component matches the data type for the data field selected (cf. "Properties of
EKM database components").
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2.5  Applying your work in the EKM Designer

Once you have finished designing the form for the key data, click Apply on the toolbar. Layout design is
closed and the program then uses the current layout in the general design mode. Click Apply on the
toolbar again. EKM changes automatically from the design mode to the read and write mode. The form
and the database design are transferred to the EKM server and saved using Apply. A read right and an
edit right are created for all form components. To enable users to view and edit the form fields, the
related rights must be assigned to the corresponding groups.

2.6  Assigning  user rights

Open the user manager using Tools -> User. On the View tab choose the Rights option so that the
rights available are displayed in the window on the right.

Assign the rights to the user groups:

 

Allocate the right marked to the user group marked
 

Allocate all rights available to the user group marked

Close the user manager. All authorized users can now read and write keys.



Part

III

EKM

093336-07-10/16Page 18/130

Manual Electronic-Key-Manager EKM

Subject to technical modification



Subject to technical modification093336-07-10/16 Page 19/130

Manual Electronic-Key-Manager EKM

3  EKM

3.1  Installation

To install the EKM, start the installation program "Setup.exe". The installation program guides you
through the installation of the application and allows you to choose the folder for the installation and the
components installed. Please pay attention to the prompts displayed during the installation. 

When EKM is started for the first time, it may be necessary to set the parameters for the connection to
the EKM server.
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3.1.1  EKM files

All files created from EKM are stored in the EKM installation path. 

When EKM is installed on Windows 7, Windows Server 2008 or Windows Server 2008 R2 and
the installation path is 'C:\Program Files\<EKM>',  the operation system redirects user specific
files to the VirtualStore. The VirtualStore is located under: 
'C:\Users\<User>\AppData\Local\VirtualStore\Program Files\<EKM>'. 

3.2  Starting program

Start EKM via the entry in the Windows start menu. On the full version, the EKM server has to be
started first. Alternatively EKM can be started by double-clicking the file EKM.exe respectively
EKMServer.exe. The first time the program is started, the Connection parameters EKM-Server window
opens in front of the program splash screen.

Enter the IP address of the EKM server and the port for the server, and accept the values using OK. For
local operation the IP address 127.0.0.1 can be used. If a connection is not established, please check,

Whether the EKM server has been started.
Whether the IP address and the port for the EKM server have been entered correctly.
Whether the TCP/IP protocol is correctly installed.

Following successful establishment of the connection, the Logon window opens. To logon please enter
your user name and password. If logon using a key has been activated in your user profile, you can
logon by inserting your key in the EKS Electronic-Key adapter. If the key does not authorize you to
logon, a corresponding message is displayed in the Logon window. The first time you start the program,
logon as the user ekm using the password ekm.   
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The EKM main window opens. If necessary, choose a different port for the EKS Electronic-Key adapter 
(cf. "EKS interface" ). Then open the user manager using Tools -> User and change the data for the
default user ( cf. "User rights"), add new groups and users in the user manager, and manage the user
rights.

When the program is quit the connection parameters and the port set for the EKS Electronic-Key
adapter are written to the configuration file ekm.ini. You will not be prompted to enter the data
again when the program is opened; the data will be retrieved from the configuration file.

  

For security reasons, do not forget to change the ekm user setup as an administrator when the
program is installed.

3.3  Quitting program

 
   
To quit the EKM, click Exit on the File menu.

3.4  User interface

3.4.1  Main window

The EKM window is the main window of the EKM program. It opens when the program is started:

 

 

The EKM main window is divided into the following areas:
 

 Menu bar  Toolbar  Status bar
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 Form area The data allocated to the key are displayed and can be changed in this area.
The design of this area can be customized to the user's specific needs in the
design mode. 

The size of the window can only be changed in the design mode.

3.4.2  Menus and toolbars

The menus and the toolbar contain different commands and buttons depending on the mode in which
you are working. The content in the read/write mode is shown in the following as an example.
 

Menu bar and toolbar  
 

The functionality on the menus and the toolbar is dependent on the user rights assigned. In the figure
shown above, a user with all administrator rights is assumed.

Menus and menu commands have shortcut keys: Press Alt and the letter underlined in the menu
name or menu command.
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Status bar 
 

 

The following information is displayed on the status bar:

 EKM server status The icon indicates the status of the connection to the EKM server. If the icon is
green, there exists a connection to the EKM server. A red icon indicates that the
connection has been interrupted. 

 Port selection The port selected for the EKS Electronic-Key adapter is displayed in the Port
field. You can select a different port from the drop-down list.

 User indication The name of the user logged on is displayed next to the user icon.

3.4.3  Help

  
To open the Help file, click the Help command on the Help menu. The EKM window opens.

In the Help file you can:

Page through the topics section by section and display topics.
Search for topics and display topics.
Add, remove and display favorites.

The following features are available using the buttons on the toolbar:

Show/hide  Shows or hides the navigation bar

Back Jumps back to the last page

Forward Jumps forward to the previous page

Home Jumps to the home page, i.e. the first page
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Print Prints the current topic

Options Hide Tabs
Back
Forward
Home
Stop
Refresh
Internet Options
Print
Search Highlight On/Off

3.4.4  Language selection

You can change between German and English while the program is running.

3.5  Reading and writing

To read key data or to write keys, proceed as follows:
 

Check the settings for the EKS Electronic-Key adapter using the manual on the EKS (key-specific
settings)
Connect the EKS Electronic-Key adapter to a power source. 
Connect the EKS Electronic-Key adapter to a serial interface or USB interface on your computer. 
Choose the port for the serial interface.

Start the EKM or change from the design mode to the start window.
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3.5.1  Reading a key

To read a key, push the key into the EKS Electronic-Key adapter. The read process starts
automatically. Progress during the read process is displayed on the status bar in Key access.

 
When the key is read, the data on the key are automatically transferred to EKM server database. Once
the read process is complete, the data are displayed on the key form. 

You can also start the read process manually:
 

 

click the Read button on the toolbar or the Read command on the Edit menu.

The data displayed on the form are overwritten on renewed reading. 

Note that the read process is dependent on the selection of the field property  OnKey:

OnKey activated:  On reading the value is read directly from the key, transferred to the database
and displayed in the form. If the key does not contain any valid data, you will receive a message
and the invalid value will be replaced by a default value.

OnKey deactivated: On reading the value is read directly from the database and displayed in the
form.

The first time fields are read without OnKey selected, the database fields are ZERO. Blank fields
are displayed in the form. 
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3.5.2  Writing a key

To write to a key, push the key into the EKS Electronic-Key adapter. First the read process starts
automatically. Then enter the data on the form (for information on data entry cf. "Data entry"). 

To start the write process, click
 

  

the Write button on the toolbar or the Write command on the Edit menu.

The progress during the write process is displayed on the status bar in Key access. 

 
 

The data are automatically transferred to the EKM database when the key is written. Once the write
process has been completed successfully, a message is displayed:

Accept the message with OK.
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The key must not be removed during the write process.

The use of duplicates in Unique fields is detected prior to executing the write process: you will
receive an error message if you have entered a value that has already been used in a field with the
Unique restriction. 

The write process is not executed.
 

3.5.2.1  Data entry

Data entry when writing to a key varies depending on the form component. 
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 cxDBTextEdit: Click the field and enter one line of text. 

     

 cxDBMemo: Click the field and enter several lines of text. 

cxDBSpinEdit: Click one of the arrows. The number is increased or
decreased. You can also enter a number directly by clicking the field.
     
 

cxDBCheckBox: Click the check box to set or activate the defined
property. A check mark appears in the check box. To deactivate the
field, click the activated check box. The check box is now empty. 
     
 

cxDBTimeEdit: Click one of the arrows. The time is put forward or put
back. You can also place the cursor directly in the field and enter a
time. The cursor moves forward automatically so that the entry is always
in the correct format.

 

cxDBDateEdit: Click the arrow. A calendar opens. Choose a date by
clicking a day directly on the calendar. Click the month bar to choose a
different month. 

You can page through the calendar using the arrow buttons on the
month bar, i.e. move back and forward. 

Click the Today button to choose today's date. 

Click the Clear button to remove a selected date.

cxDBImage: Click the form component using the right mouse button. A
context menu appears:

Cut removes the image from the form component and saves it to the
Windows Clipboard.
Using Insert you can paste an image from the Clipboard into a form
component of type cxDBImage.
Using Copy you can copy the image from the form component to the
Clipboard. 
Using Delete you can delete an image from the form component.
Using Load you can open a dialog box for opening a file. Select the
image file and accept your selection by clicking the Open button.
You can save an image using Save As. The Save As window opens
first. Select a folder, enter a file name and accept your entries by
clicking the Save button.
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 cxBitstring: Click the arrow. A dialog box with check boxes opens
containing the bits to be set. Comments related to the bits are
displayed. Set the bits in the dialog box by selecting the related check
boxes. When you close the dialog box, the bits set are displayed in a
corresponding decimal or hexadecimal character string.

     

            

 cxDBExComboBox: Click the arrow to open the pull-down menu.
Select an entry on the pull-down menu. The selected value is not
written to the key, instead a value saved in the Layout Designer for
this menu entry is written to the key.  You cannot enter any text in the
field. 

     

cxDB_ComboBox: Click the arrow to open the pull-down menu.
Select an entry on the pull-down menu. You can also enter text in the
field and transfer the text to the key or to the database using Write. 

 

cxDBPassword: Click the field and enter text. The text entry is hidden
using the character " * ". For data security reasons " *** " is displayed
when you leave the field with the cursor.
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3.5.3  Using templates

Using templates you can save defined values in form fields and use these values as required. Templates
can be used to speed up writing similar data to keys.

To create and use templates, proceed as follows:

First create a template:

Enter the required values on your form. There must be a key in the EKS Electronic-Key adapter to
enter data. 

Click Tools -> New template. Enter a name for the new template in the Save template window and
accept your entries with OK.  

All fields that have been enabled in the Database Designer for use in templates are saved in the
template with the value entered (cf. "Properties of the data fields"). 

The template is a TXT file that is saved on the EKM server.
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How to use a template:

Click Tools -> Template list. A list is opened with the templates already added. Select the template
you want to use.

Once a template has been selected, the Template button is available on the toolbar.

Insert the key you want to write in the EKS Electronic-Key adapter. Click the Template button on the
toolbar or use the Template command on the Tools menu. The values saved in the template fields
appear on the form.   
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If necessary, add data to the form and click Write to transfer the data to the key.

3.5.4  Discarding changes

If you do not want to save changes to key data, but instead want to discard the changes, click 
 

 
  

the Discard button on the toolbar or the Discard command on the Edit menu.
 

The data last transferred to the key are displayed on the form. 

3.6  Database viewer

To open the database viewer, click 
 

 
 

the Database command on the Tools menu or
 

 
 

the Database button on the toolbar. 

The Database viewer window opens

Here you can see all the key data already entered. The data fields written to the key have a yellow
background.
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3.6.1  Working with data

Lists of data records are displayed in tabular form in the EKM. Examples of these data tables are the
data views in the database viewer and in the Database Designer. The figure below shows all key data
already read into the database viewer.

 

Various functions are integrated into the tabular view: 

Searching
Changing the position of a column
Sorting by columns
Grouping by columns
Filtering data

You can mark a row by clicking the row using the mouse. The functions for changing lists of data
described here are not saved when the related data view is closed.

These functions are not always integrated into every data table in their entirety.
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3.6.2  Changing data in the database viewer

In the database viewer, you can only change data that are not written to the key. Data fields that are
written to the key have a yellow background. To change data, click the data field you want to change.
Overwrite the data field with the value that you want to enter in the data field.

 

Once you have made all the necessary changes, leave the database viewer using OK. 

Your changes will be transferred to the EKM server as soon as you leave the modified field in the
database viewer with the cursor or close the database viewer.

The database viewer includes field-specific windows, pull-down menus and pre-formatted fields for
entering data (cf. "Data entry").
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3.6.3  Deleting database records in the database viewer

To delete data records in the database viewer, select a data record by clicking it. Then click the Delete
button.

A warning message is displayed. Accept the message using Yes if you want to delete the
selected data record and the related data. Your changes will now be transferred to the EKM
server.

3.6.4  Exporting data

In the database viewer you can export key data.
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During a CSV export all key data with the exception of the Memo, Graphic and StringPassword data
types are exported to a CSV file. 
The first row in the export file contains the names of the database fields
Order of the database fields:

Database field KEYID
Database field LOCKED
Database fields with the key data. The sequence is the same as the order on the key
Remaining database fields. The sequence is the same as the order defined in the Database
Designer

During a SmartCard export the serial numbers of the keys (KEYID) are converted to the card code for
the SmartCard and saved as file names for zero-byte files.

3.6.4.1  CSV export

If you want to save the key data in a CSV file, click the CSV export button in the database viewer. 
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The Entry of export file window opens.

Select a folder and enter a file name for the CSV file. Accept using Open. After the export a message is
displayed:
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3.6.4.2  SmartCard export

The SmartCard export is used to convert the key serial numbers (KEYID) to the card code for the
SmartCard. The card code is saved in the file name for a zero-byte file using the following syntax:

USERMAN_CARDxxxxxxxx.DAT
(xxxxxxxx stands for the card code). 

To export the serial numbers for keys entered as SmartCard card code, click the SmartCard export
button in the database viewer. 
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The Entry of export folder window opens.

Select a folder and accept your selection using OK. 
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After the export a message is displayed:

In the export folder you will now see the files with the related card codes:

Locked keys are not saved.

The key serial number is a sixteen digit hexadecimal number (8 bytes). For the conversion to the
card code this number must be converted into an eight digit hexadecimal number (4 bytes): 

The 8 byte key serial number is divided into two 4 byte values.
The two 4 byte values are added together. Any overflow is ignored. The resulting 4 byte value is
the card code. 
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3.6.5  Searching for data

Mark a field in a column with a yellow background in your table overview and type the search term or the
character string you want to find. The cursor jumps to the next data record that starts with the character
string entered. 

The search function is integrated into the database viewer only for the fields with a yellow background.
These fields cannot be changed in the database viewer (cf. "Changing data in the database viewer"). 

3.6.6  Filtering data

When you filter data, you formulate criteria that are used to select the data for the view. To activate the
filter selection, click the filter selection for a column. A list of possible selection conditions opens. 
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If you have selected Custom as the criterion, the Custom Filter window opens. 

Here you can link two conditions using ... 
and (both expressions are true)
or (at least one expression is true)

    A list of operators is available for formulating the specific condition. 

Once you have used a filter on a table, the expression appears in the filter status bar. 

Here you can open the Filter builder window using the Customize button. 
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In this window you can build an expression with as many conditions are required: 

You can.. 

Select the logical operator for the arguments  
Select the column to which an argument is applied  
Select the condition 
Enter the criterion as required  
Add or remove a single condition or a further group of conditions   

Filter expressions can be saved using Save As and retrieved using Open.
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3.6.7  Moving columns

To change the position of a column in a table, drag the column to the right or left. Two green arrows will
indicate the new position of the column. The column is moved when you release the mouse button. 

3.6.8  Sorting data

To sort a table based on the content in a column, click the column. The arrow indicates whether the
sort order is ascending or descending. The existing sorting is reversed if you click the column again. 

You can use several columns for the sorting by holding the Shift key when you click the column
headings. If you click a column with the Ctrl key pressed, this column is no longer used for sorting. 
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3.6.9  Grouping data

Grouping the data in a table by a column means that all data records with identical fields in the related
column are combined to form a group. 

To group by a column, simply drag the column to the grouping bar. You will see this data view: 

Groups can be formed based on the content of several columns. The order for forming the groups can be
changed in the grouping bar. 

To undo a grouping, drag the column back to the column bar. 
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3.7  Importing data

You can import key data into the key database. The data to be imported must be CSV format. The first
row in the CSV file contains the database field names. Only fields that can be unambiguously allocated
and that match existing database fields are imported. The file to be imported must contain as a
minimum the data field KEYID with values. If database fields are missing during the import, these fields
are ZERO after the import.

To edit the CSV file use an editor that does not change the structure of the file.

To import key data into the key database, click Import on the Tools menu. The Database import from
CSV file window opens.

Select the file to be imported and accept using Open. The import progress and, on completion of the
import, the import logger are displayed in the Database import from CSV file window.  
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Using Details you can close or open the import logger. 

If the import file contains data records that already exist in the key database, you will receive a
message:

Select ...

Yes if you want to overwrite the key data for the KEYID displayed with the data from the import file.
No if the key data for the KEYID displayed are not to be overwritten.
Cancel if you want to cancel the import. The data already imported are retained.
Yes to all if you want to overwrite the key data for all already existing KEYIDs with the data from the
import file.

Please note that a data record will be ignored during the import in the following cases:

The data record contains invalid data. Example: 
Characters that are not allowed in the related data field 
Values that are below the minimum or above the maximum for the related data field 

The data record contains a duplicate value for a database field with the Unique restriction.

Using Tools -> Show import log you can open the import logger for the last import. The log file is saved
on the EKM server in the ImportLog folder.
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3.8  Key export/import

 

With the function key export respectively key import the data set of the presently displayed key can be
exported respectively imported into an optional folder.

Key export
In order to export the data set, click in the menu File on the menu command Key export. 

The window key export to csv-file opens.

Enter a file name and store the file with Open.

Key import
In order to import the data set, click in the menu File on the menu command Key import.

The window key import from csv-file opens.

Choose the file to be imported and confirm with Open.
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In the window key import from csv-file now the import progress and upon completion of the import the
import logger is displayed.

On Details you can close respectively reopen the import logger again.

The read values are displayed on the user interface, but not yet transferred into the data base. Only by
using the function Write the imported values will be written on the key and into the data base.

Be aware, that in the following cases a data set is ignored for import:

The data set contains invalid data, for example:

Characters which are prohibited for the respective data field

Values which exceed the minimal or maximal size of the respective data field

The data set contains a duplicate value for a data field with the Unique limitation

The functions import and export can only be executed when key is plugged.

The KeyID is not imported.

Data fields of type Memo, StringPassword and Graphic get not exported.
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3.9  Design mode

To open the design mode, on the Tools menu click Design mode. The Database, Layout, Cancel, and
Apply buttons appear on the toolbar. 

In the design mode you can: 
 

Design the database for the key data
Design the layout for the key data form
Transfer all changes to the key data form and all changes to the database to the EKM server using 
Apply
Discard your changes to the key data form and to the database using Cancel
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3.9.1  Designing a database

To design a database for key data, in the design mode click the Database button. The Database
Designer window opens. 

In the Database Designer you can: 

Insert data fields
Delete data fields
Change data fields

You can select the buttons in the Database Designer by:

Clicking the button directly using the mouse or
Using shortcut keys Alt+ the underlined letter

The fields with the OnKey option are saved on the key.
  

On leaving the design mode, do not forget to transfer your changes to the EKM server using Apply
(cf. "Applying your work in the EKM Designer").
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3.9.1.1  Properties of the data fields

 

You can design the database for the key data to suit your requirements using the EKM in the design
mode. The only exceptions are the KEYID and LOCKED data fields that are hard programmed. These
fields are added automatically when the database is created. The KEYID field can only be read. The
LOCKED field can only be changed using the database viewer.

The database comprises:
 

Fields that are written to the key during the write process

Data that can be retrieved centrally from the database, but not written to the key. 

The amount of memory space for the data fields written to the key is limited. Please see the data
sheet on the Electronic-Key for information on the amount of memory available on the key used.

  

Data fields that are not written to the key can be added almost without limitation. However, for fast
data transfer, it should be ensured that excessively large image files are not used.

The following data field properties must be defined when designing the database:

FieldNo Information on the order in which the fields are displayed in the database viewer.
A field can be moved up or down in the display order using Up and Down. The number is
changed automatically when a field is moved. The number is automatically incremented
when a field is added.

 

OnKey
 

Activated: the field data are saved on the key when data are written to the key.
Deactivated: the field data are not saved on the key when data are written to the key and
can only be seen on the data form. 
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Fieldname
 

Name of the data field
Spaces and special characters cannot be used with the exception on the underscore ("_").

 

Type
 

Data type
The data types listed below are available:

Data type On Key possible Number of bytes
Bit  X 8 bits = 1 Byte

ShortInt (-128...127 ) X 1 byte

Byte (0...255) X 1 byte

SmallInt (-32768...32767) X 2 bytes 

Word (0...65535) X 2 bytes

Integer (32 Bit mit Vorzeichen) X 4 bytes

Float X 8 bytes

String X Maximum 116 bytes

String Maximum 250 bytes

StringBlankFilled: string filled
with ASCII blanks (= 20hex)

X Maximum 116 bytes

StringBlankFilled: string filled
with ASCII blanks (= 20hex)

Maximum 250 bytes

StringPassword: string hidden
with "***" on the display

Maximum 250 bytes

Time X 8 byte

TimeAscii: ASCII time format
Format on key: hhmmss00

X 8 byte

Date  X 8 byte

DateAscii: ASCII date format
Format on key: YYYYMMDD

X 8 byte

Memo

Graphic

CRC: checksum on key X 2 bytes

BitString: integer multiple of 1
byte

X Maximum 8 bytes

Nibble X 4 Bit
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Fields with the data types CRC, DateAscii or TimeAscii can only be defined as OnKey fields.

StartByte Defines the first byte of the data field on the key
The numbering starts with " 0 "

 Length Defines the length of the data field in bytes. This length can only be freely defined for
the data types BitString and String.

 BitNo  Defines the bit used in the byte
 

On a field of the type Bit.

On a field of the type CRC here the StartByte is defined.

ON fields of the types Nibble: 0 - bit no. 0-3; 4 - bit no. 4-7.

 DisplayType  For the data types Byte, Word, Bitstring and CRC you can choose between decimal
and hexadecimal notation for display.

Template Activated: the field is enabled for integration in a template: The value from the
allocated form field is applied when a template is created, i.e. the value is saved
in the template.

Deactivated: the field is ignored when a template is created.

The template function cannot be activated for the fields of type Memo, Graphic, CRC
and StringPassword.

Unique Activated: it is not possible to save duplicate or multiple entries in the field.
Duplicates will be detected on writing.

Deactivated: there is no unique restriction for the field.
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Notes on the data type CRC

The CRC field forms a checksum using a configurable part of the key user data and the serial number. 
The area of the user data included in the checksum is defined using the Startbyte and Length fields.

The field CRC can be placed with a freely selectable StartByte on the key in a flexible manner. For the
input of the StartByte the field BitNo is used.

Example:

In the above example the checksum is formed using the key data from byte 0 to byte 44. The CRC field
is saved in the bytes no. 46 and 47.

You can only define one field of type CRC per data base design.

The field name is defined fixed as KEYCRC.

Is the StartByte located within the controlled CRC range, an error message occurs.

The checksum is only calculated when writing on the key. 
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Notes on the data type BitString

The BitString field contains a defined number of bytes. The field is used in conjunction with the
cxDBBitstring form component for defining bits. You can save comments on the bits in the Database
Designer. 
To save comments on the BitString field in the Database Designer, place the cursor on a BitString field
and click the BitString editor button.
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The BitString editor opens. Enter the comments on the bits in the Description field:

Accept your entries with OK. During data entry the comments added are displayed in a cxDBBitstring
form component related to the BitString field:
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3.9.1.2  Order of the bytes on the key

The data are saved on the key using the following scheme:

  

The little endian format is used for the order of the bytes on the key:

 Word 2 bytes
Order on key Low byte - high byte
Example
Dec. value 258
-> hex. value

On key

 

 Integer 4 bytes
Order on key Low word - High word
Example
Dec. value 1609060
-> hex. value
On key
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 CRC 2 bytes
Order on key Low byte - high byte
Example
Dec. value 12958
-> hex. value

On key

 

 Float 8 bytes
A floating number with eight bytes (64 bits) is divided into three fields:

The value v for the number is defined as follows:

If 0< e < 2041, v = -1 s  * 2 (e -1023) * (1.f)

If e =0 and f<>0, v =(-1) s * 2 (-1022) * (0.f)

If e =0 and f=0, v =(-1) s * 0

If e =2047 and f=0, v =(-1) s * Inf

If e =2047 and f<>0, v is a NaN value

 

 Date and Time 8 bytes
A floating number in accordance with IEEE 754 with eight bytes (64
bits) is divided into three fields. The integer part corresponds to the
number of days since 30.12.1899. The fractional part defines the time.

 DateAscii 8 bytes
Order on key YYYYMMDD
Example
Date 13 May 2005
On key

 

 TimeAscii 8 bytes
Order on key HHMMss00
Example
Time 12:35:48
On key
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3.9.1.3  Inserting data fields

To insert data fields, click the Insert button in the Database Designer.

Once you have entered the properties for the new data field and have selected the data type for the field,
click OK to apply the changes to the database locally. In the layout design mode you can now bind a
form field to the new data field (cf. "Properties of EKM database components"). 
To transfer your changes to the EKM server, click Apply on the toolbar (cf. "Applying your work in the
EKM Designer").
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3.9.1.4  Deleting data fields

To delete data fields, mark the data field to be deleted in the Database Designer and click the Delete
button.

A warning is displayed first. If you want to delete the data field marked or the marked row in the 
Database Designer, accept the warning with Yes. If the deleted data field was bound to form
components, these bindings will also be deleted. A message is displayed:

 

The form fields with a red background must be re-assigned to a data field. 
 

Your changes are initially applied locally. 
To transfer the modified database design to the EKM server, you must click Apply on the toolbar  (cf.
"Applying your work in the EKM Designer"). 

Note that on the deletion of a data field, all related data in the database will also be deleted! 
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3.9.1.5  Changing data fields

To change data fields, click the data field in the Database Designer and overwrite the property to be
changed or select a different property.

If the modified data field was bound to form components, these bindings will be deleted. The following
message is displayed:

The form fields with a red background must be re-assigned to a data field. 

Your changes are initially applied locally. To transfer the modified database design to the EKM server,
you must click Apply on the toolbar (cf. "Applying your work in the EKM Designer"). 
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In some circumstances all database entries in the column modified will be deleted if changes are
made to the data fields: this situation will occur if

The data type is changed

A change of the length of the string is not a change of the data type!
Is the string length reduced, the characters beyond the new length are cut.

If you activate the Unique property for a field and the column contains duplicate entries in the
database, you will receive a message on applying the design. 

The activation of the Unique property will not be applied. Database entries will not be deleted.
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3.9.2  Designing the layout

To design the layout for the key data form, in the design mode click the Layout button. The EKM
Designer and Alignment palette windows open. These windows are beside and above the EKM main
window and can be moved as required. 

Using the EKM Designer you can design and change the key data forms by:

Inserting form components in the key data form
Assigning properties to form components
Moving form components
Aligning form components
Deleting form components

Make sure that that you enable newly added form components for viewing and editing in the user
manager once you have completed your work in the Layout Designer (cf. "Assigning rights to a
group"). On leaving the design mode, do not forget to transfer your changes to the EKM server
using Apply (cf. "Applying your work in the EKM Designer").
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3.9.2.1  An overview of the EKM Designer

You can use the Layout Designer to create and design forms for viewing and changing key data. You
can design the layout of key data forms with the aid of three windows:
 

EKM (the form window)
EKM Designer
Alignment palette

Edit menu with the commands:
Undo, Redo, Cut, Copy, Insert
The menu commands on the Edit menu relate to the last action in the layout design, or to marked
form components, or form components saved to the Clipboard. 
 

Toolbar: 
The layout design is quit using Apply and the current form saved temporarily and locally: the client
application continues to use the current form. After Apply is clicked, the program changes to the
first window in the design mode  (cf. "Design mode"). The program continues to use the current
form. To transfer the form to the EKM server and finally save it, click the Apply button on the
toolbar again. Using Cancel you can return to the last form design saved.
Form area:
Area where the form components are inserted and viewed. If no forms have been created, the form
area is empty.

Marked form components: 
In the form area you can move and position the components as required, the appearance of the
components and other properties such as the binding to a database can be changed in the EKM
Designer.

You can also change the size of the main window in the design mode.
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3.9.2.1.1 EKM Designer

Component bar: 
Choose here the type of form component you want to insert on your form.

Component inspector: 
Displays a list with all the properties for the component currently marked. To edit a property,
click the row for the property.

Status bar: 
Displays the description for the property you are currently editing.

3.9.2.1.2 Alignment palette

Use the Alignment palette to align several form components in the form area.
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3.9.2.2  Form components

Forms for viewing the key data can contain various form components. 

The form components are divided into

EKM database components: form fields containing data and that are bound to the key database and
display key-dependent data.

EKM standard components: form components without a data binding for fixed text, images, borders,
etc. 

You will find the components on the component bar in the EKM Designer on the EKM Database and
EKM Standard tabs. 
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EKM database components are::

cxDBTextEdit Text field: is used for displaying and entering text of limited length.
                   

cxDBSpinEdit Spin-edit field: displays integers. The number can be increased or
decreased using the arrow buttons.
                   

                   

cxDBTimeEdit Time-edit field: is used for displaying and for entering the time.

                   

cxDBDateEdit List box with calendar: is used for displaying and for entering the
date.
                   

   

cxDBCheckBox Check box: is used for activating and deactivating defined  criteria. 
                   

   

cxDBMemo Memo field: is used for displaying and entering text of unlimited
length. 
                   

   

cxDBImage Graphic field: can be bound to database fields of type Graphic.
Graphic formats: JPG, JPEG.
                   

   

cxDBPassword Password field: is used for the hidden entry of passwords and is
bound to database fields of type StringPassword.
                   

cxDBBitstring Bit entry window: is used for setting bits in a defined number of
bytes. The display type in the form field and in the database viewer
is a character string in hexadecimal or decimal notation.
                   

   

cxDB_ComboBox Pull-down menu: is used for the selection of a menu entry. With the
selected menu entry a deposited value is written to the database
and possibly to the key. The form field can be bound to database
fields of the type String. 
                   

cxDBExComboBox Pull-down menu: is used for the selection of a menu entry. With the
selected menu entry a deposited value is written to the database
and possibly to the key. The form field can be bound to database
fields of the types String, Nibble, Byte and Word. The displayed
value and the value of the data can be different.

 EKM standard components are:

cxGroupBox Group box: is used to visually combine several form fields in a
group; the group box features a label that can be assigned in the
component inspector. When a group box is moved, all allocated
elements are moved as one element.
                   

                

Bevel 3D blank field: is used as a fixed structuring element.

                

cxLabel Label: is used for inserting labels.

cxImage Image field: is used for inserting graphics; the following formats are
accepted: JPG, JPEG, BMP, ICO, EMF, WMF
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The list of properties for the currently marked component is displayed in the component inspector. 

In the component inspector you can access the properties for the form components and change the
properties. The component properties are displayed in alphabetical order.

All form components have general properties:

Design of the component (border, background color, font, shading, etc.)
Internal name for the component
Position on the form or within a group box
Size of the form component
Hint for a form component
Sequence number for navigation on the form using the Tab key

In addition to these properties, you can make other settings in the component inspector as a function of
the form component inserted:

For EKM database components, a data field must also be selected for the components using
DataBinding -> DataField to bind the component with the database field. When a database
component is inserted, there is initially no binding to a data field. 
For the EKM database components cxDB_ComboBox and cxDBExComboBox, menu entries for
display on the pull-down menu can be entered using Items. For the component cxDBExComboBox a
value in the format String, Byte or Word is saved for the menu entry. The menu entries are added after
binding to a data field.
Using the EKM standard components cxGroupBox and cxLabel you can enter the label text for the
components. By default the labels are cxGroupBox1,  cxGroupBox2 or cxLabel1, cxLabel2.
With the EKM standard component cxImage you can also select an image file in one of the formats
JPG, JPEG, BMP, ICO, EMF, WMF. By default an image file is not selected.  

Note that the properties are grouped in the component inspector. If you want to view a group of
properties, click the plus sign in front of the group; if you want to hide a sub-group, click the minus
sign in front of the group.
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3.9.2.2.1 General properties

All components have general properties. You can change these properties in the component inspector
by clicking a property field and entering the value required. 

The following list contains all the general properties and the valid entries:

   

Internal component name

Name Description Valid values
Name Defines the internal form field

name:
pay attention to clear labeling: e.g.
PersonnelNumber or
cxDBTextEdit3_Name.

All characters except special characters
such as ö, ä etc. as well as the hyphen
("-"), forward slash ("/"), backward slash
("\") and space (" ").
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Position of the component

Name Description Valid values
Left Defines the position of the left

edge of the component in pixels,
starting from the left edge of the
form or the group box.
 

Integer

Top Defines the position of the top
edge of the component in pixels,
starting from the top edge of the
form or the group box.

Integer

   

Size of the component

Name Description Valid values
Height Defines the height of the

component in pixels 
Integer 

Width Defines the width of the
component in pixels

Integer 

The height can only be entered directly in the Height field for the form components cxDBMemo,
cxDBImage, cxGroupBox, Bevel, Image. The height of the other components is automatically
adjusted to the font size set (Style -> Font -> Size).  

   

Design of the component: Style

Name Description Valid values
Style

BorderColor Color of the component border Select a color from the pull-down menu

BorderStyle Style for the component border: e.
g. flat, 3D etc.

Select a style from the pull-down menu

Color Component background color Select a color from the pull-down menu
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Design of the component: Font

Name Description Valid values
Font Font for the component content In the Font field you can open a dialog box

where you can access the fonts installed
in the operating system. The font, its size
and color, etc. can be selected in the
dialog box.

Charset Character set that is used as the
basis for the component content.

Select a character set from the pull-down
menu

Color Font color Select a color from the pull-down menu

Height Scaling value for the font size
referred to the screen resolution

Integer 

Name Font Select a font from the pull-down menu

Pitch Adjusts the character spacing
 

Size Font size Select a font size from the pull-down menu

   

Design of the component: Font  Style

Name Description Valid values
Style
fsBold Bold font Activated / deactivated

fsItalic Italic font Activated / deactivated

fsStrikeOut Struck-through font Activated / deactivated

fsUnderline Underlined font Activated / deactivated

   

Design of the component

Name Description Valid values
Shadow Shadow: places a shadow behind

the component
Activated / deactivated

Transparent
Border

Transparent border Activated / deactivated
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Navigation using the Tab key

Name Description Valid values
TabOrder Defines the order in which the

cursor moves between the
components when the Tab key is
used for navigation

Integer 

   

Hint for component

Name Description Valid values
Hint Hint that appears when you move

over the component with a key
inserted

All characters except special characters

ShowHint Defines whether the hint is shown Activated / deactivated

3.9.2.2.2 Properties of EKM database components

EKM database components have general properties as well as an allocation to a database field:

  

Data used for field content

Name Description Valid values
DataBinding Indicates the type of component  

DataField Indicates the data field that is
used to provide the data for the
form component

Select a database field from the pull-down
menu
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The selected form component must match the data type of the database field allocated (cf.
"Properties of the data fields"). Valid bindings between form components and data types for an
allocated database field are:  

cxDBTextEdit Text field: can be bound to database fields of type
String (String, StringBlankFilled ) and number
(SmallInt, ShortInt, Byte Word, Integer, Float), the
KEYCRC field or the hard programmed KEYID
field.
                    

   

cxDBSpinEdit Spin-edit field: can only be bound to database
fields of type number.
                  

   

cxDBTimeEdit Time-edit field: can only be bound to database
fields of type Time and TimeAscii
                  

   

cxDBDateEdit List box with calendar: can only be bound to
database fields of type Date and DateAscii.
                     

cxDBCheckBox Check box: can be bound to database fields of type
Bit and the hard programmed LOCKED field.
                

   

cxDBMemo Memo field: can be bound to database fields of
type Memo.
                

cxDBImage Graphic field: can be bound to database fields of
type Graphic. Graphic formats: JPG, JPEG.
                

cxDBPassword Password field: can only be bound to database
fields of type StringPassword.
                

cxDBBitstring Bit entry window: can only be bound to database
fields of type BitString.
                

cxDB_ComboBox Pull-down menu: can only be bound to database
fields of type String.
                      

cxDBExComboBox Pull-down menu with saved values: can be bound to
database fields of type String, Byte and Word. The
database field selection is based on the values that
are to be saved for the entries visible on the menu:
example: menu entry: Level1 - value saved: 001 =>
Field with data type String
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Menu items can be saved for the combo boxes cxDB_ComboBox and cxDBExComboBox using Items: 

Click the button in the Items field after you have bound the combo box to a data field. 
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A field-specific string list editor opens:  

String list editor: cxDB_ComboBox

 

Using the Add button you can add new entries that are to be displayed on the pull-down menu.

To delete entries, click the row to be deleted and click the Delete button.
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String list editor: cxDBExComboBox

Add a new row per menu item using the Add button. In Description enter the text that is to be
displayed as the menu entry on the pull-down menu. In Value enter the value that is to be saved on
the selection of the related menu item. Ensure that the data entered under Value match the related
database field.

To delete entries, click the row to be deleted and click the Delete button.
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3.9.2.2.3 Properties of EKM standard components

EKM standard components feature some of the basic properties and component-specific properties:

cxGroupBox

 

Label

Name Description Valid values
Caption Text that is used to label the group

box
All characters including the special characters

Alignment Indicates how the label is aligned on
the group box

Select an alignment from the pull-down menu

 

To insert components in a group box, the group box must first be inserted in the form, then form
components can be positioned directly in the group box. However, you can also insert the components
in the group box using Cut and Insert. If you move a group box, the form components contained in the
group box are also moved. 

cxLabel

 

Label

Name Description Valid values
Caption Text used for the label All characters including the special characters
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Bevel

 

Profil

Name Description Valid values
Shape Assigns a profile to an empty field Select a profile from the pull-down menu

cxImage
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Image source

Name Description
Picture The picture wizard is displayed. The picture wizard is used to insert and remove images

from the cxImage component:

You can perform the following operations in the picture wizard:
     

     

Click Open to open an image file and to insert it in the image field. You can insert image files
with the following formats: JPG, JPEG, BMP, ICO, EMF, WMF.

     

Using Save, you can save an image that you have opened in the picture wizard.

     

Using Copy, you can copy an image that you have opened in the picture wizard to the
Clipboard.

     

Using Insert you can insert an image from the Clipboard in the image field.

Using Remove you can remove an opened image from the picture wizard. The image is then
also removed from the image field.
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3.9.2.3  Inserting form components

To insert form components, click the required component on the component bar. Then click the form in
the position where you want to insert the form component. 

The form component is inserted in the form with default properties. Change the properties of the new
form component in the component inspector. You can also move the form component again if required.
The component that was last inserted is at the front. 
 

To insert components in a group box, the group box must first be inserted in the form, then form
components can be positioned directly in the group box. However, you can also insert the components
in the group box using Cut and Insert.

Make sure that that you enable newly added form components for viewing and editing in the user
manager once you have completed your work in the Layout Designer (cf. "Rights available").
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If you bind an EKM database component to an invalid database field, you will receive a message:

An invalid binding to a database field occurs if the data type for the selected database field does
not match the form field. The invalid database binding is deleted.  

3.9.2.4  Selecting form components

You can see which form component is selected using the black anchor points. There are several ways
you can select a component or several components:

Click the component using the mouse. If you keep the Shift key pressed, you can select several
components.

Keep the Ctrl key pressed and, using the left mouse button, drag an area around the form
components you want to mark. Release the mouse button, all components in the area are marked.

If you want to remove a component from the selection, click the component with the Shift key pressed.
To clear a selection, click an empty part of the form area.
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3.9.2.5  Changing form components

When form components are inserted, the components have the default properties. You can change the
position and the size of the component using the mouse pointer and keyboard commands. All the
properties of a component can be changed in the component inspector:

Select a component by clicking it. All the properties of the selected component are displayed in the
component inspector. 
Change a property by clicking the property field. When the field is clicked it is opened for editing, i.e.
it is possible to write to the field.
Enter the required values in this field.  

If you enter invalid values for properties, the changes are not applied  (cf. "General properties" ff.). A
message is displayed:
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If you bind an EKM database component to an invalid database field, you will receive the
message:

An invalid binding to a database field occurs if the data type for the selected database field does
not match the form field. The invalid database binding is deleted. 

3.9.2.6  Cutting form components

Select one or several form components:

On the Edit menu click the Cut command
Or pressing Ctrl + X

The selection is now on the Clipboard and can be inserted in a different position.

3.9.2.7  Copying form components

Select one or several form components:

On the Edit menu click the Copy command
Or press Ctrl + C

The copy is now on the Clipboard and can be inserted.

3.9.2.8  Inserting a form component

You can insert form components you cut or copied to the Clipboard by: 

Clicking the Insert command on the Edit menu
Or pressing Ctrl + V

You will see the new component on the form. 

On insertion the internal component name is changed if a component with the same name already
exists on the form.
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3.9.2.9  Removing form components

Select one or several form components and press the Delete key.

3.9.2.10  Moving form components

To move a component, proceed as follows:

Select a component.
Drag the component over the form with the mouse button pressed. You will be to see the new position
of the selected component using the black border. The co-ordinates for the new position are also
displayed in the hint (yellow field underneath the mouse pointer).
Release the mouse button when you have reached the desired position.

You can also move one or several marked form components using keyboard commands:

Select one or several form components
Press the Ctrl + arrow keys to move the component up, down, to the right or to the left.

If you move a group box, the form components contained in the group box are also moved.

3.9.2.11  Aligning form components

Select form components and click an alignment tool on the Alignment palette. 

The following alignment tools are available:

      

Aligns the left edges of the form components with the component marked first

      

Aligns the vertical center line of the form components with the component marked first

              

Centers the form components horizontally in the form area or in a group box
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Evenly spaces the form components horizontally

      

Aligns the left edges of the form components with the component marked first

      

Aligns the top edges of the form components with the component marked first

      

Aligns the horizontal center line of the form components with the component marked first

      

Centers the form components vertically in the form area or in a group box

      

Evenly spaces the form components vertically

Aligns the bottom edges of the form components with the component marked first

3.9.2.12  Increasing and reducing the size of form components

You can increase or reduce the size of one or several marked form components using keyboard
commands:

Select one or several form components.
Press Shift + arrow keys to change the size of the component. 

The height can only be set for the form components cxDBMemo, cxDBImage, cxGroupBox, Bevel,
Image. The height of the other components is automatically adjusted to the font size set (Style ->
Font -> Size). 
 

3.9.2.13  Undoing actions on the form design

You can undo the last action in the Layout Designer by

Clicking the Undo command on the Edit menu
Or pressing Ctrl + Z

3.9.2.14  Redoing actions on the form design

You can repeat the last actions made in the Layout Designer by clicking the Redo command on the
Edit menu.
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3.9.3  Applying your work in the EKM Designer

Once you have finished designing the database or a form for the key data, click the Apply button on the
toolbar. EKM changes automatically from the design mode to the read and write mode. You can
transfer the form and database design to the EKM server and save them using Apply.
 

If you have changed the form, you must assign the corresponding user rights to the newly added form
components. Otherwise it will not be possible to edit the form components and the components will
also not be shown. For this reason, when you apply a modified form the following message is displayed:

If you have changed the database design, the data in the database may be deleted in certain
circumstances (cf. "Changing data fields" ). For this reason when you apply a modified database
design, the following message is displayed:

If you activate the Unique property for a field and the column contains duplicate entries in the database,
you will receive a message on applying the design. 

The activation of the Unique property will not be applied. Database entries will not be deleted.
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3.9.4  Cancelling your work in the EKM Designer

If you want to cancel your work on the database or on a form, click the Cancel button on the toolbar.  

Your changes will not be saved and will also not be transferred to the EKM server. For this reason,
when you use Cancel the following warning is displayed:

Accept using Yes if you want to cancel your work in the design mode. EKM automatically changes
from the design mode to the read and write mode and loads the last form that was applied.
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3.10  User rights

To manage users, groups and rights, on the Tools menu click the User command.  The User manager
window opens.

In the User manager window you can: 

View groups, rights available and users
Edit, add, remove and copy groups
Allocate rights to the groups, or remove rights from the groups
Edit, add and remove users
Allocate users to the groups, or remove users from the groups
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By default the Administrators group has the following rights and users:

Group  Administrators Rights: 
Button_Database_Edit
Button_Database_Visible
Button_Designer
Button_Import
Button_ImportLog
Button_TemplateList
Button_TemplateRead
Button_TemplateWrite
Button_Undo
Button_UserManager
Button_WriteKey

Users: ekm

After installation change the user name and the password for the default administrator ekm. Add
new users and new groups as necessary. Add the available rights to the related groups (cf.
"Rights available").

During this process ensure that a user group has the right to access the user manager (=
Button_UserManager) and note the related user names and passwords to ensure that it is
possible to change the access rights and user data. 
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3.10.1  Managing groups

All groups already added are displayed in the user manager in the left window under Groups. To display
all the rights held by a group, choose Rights on the View tab. All rights assigned to a group are listed
underneath the group name. To display the rights held by a group, click the plus sign in front of the
group name. To hide the rights held by a group, click the minus sign in front of the group name.  All the
rights available can be seen in the window on the right.

To display all the users in a group, choose User on the View tab. All users belonging to a group are
listed underneath the group name. To display the users in a group, click the plus sign in front of the
group name. To hide the users in a group, click the minus sign in front of the group name.  All the users
added can be seen in the window on the right.
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3.10.1.1  Adding groups

To add a group to the existing groups, click Add on the Group tab on the menu bar on the left. 

The Edit group window opens.

Enter the group name and also a description of the group as necessary.

3.10.1.2  Editing groups

To edit a group, select a group in the window on the left under Groups by clicking it. Click Edit on the
Group tab on the menu bar on the left.  

The Edit group window opens.

You can change the name and the description of the group. Accept your changes by clicking the OK
button.

If you change the name of a group, the existing allocations of rights and users to the group will be
deleted. You must again assign rights and users to the group.
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3.10.1.3  Removing groups

To remove a group, first select the User view. Now mark the related group by clicking the group. Click 
Remove on the Group tab on the menu bar on the left. 

A window opens where you can accept your selection using Yes if you want to delete the group.
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3.10.1.4  Copying a group

When a group is copied, all the rights assigned and, optionally, all the users assigned to the original
group are copied. To copy a group, select the related group by clicking the group. Click Copy on the
Group tab on the menu bar on the left. 

The Edit group window opens.  

Assign a new group name and accept your entries using OK. In the next window you can define
whether you want to copy to the group all users assigned to the existing group.

Accept the copying of the user allocations using Yes or reject the copying of the user allocations using
No. The group is inserted with all rights and, as required, users and added using the new group name.
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3.10.2  Managing rights

To display all the rights available, choose Rights on the View tab. All rights available are displayed in
the window on the right under Rights available.

3.10.2.1  Rights available

In the EKM the following rights can be assigned in the user manager to the groups added:

Button_Database_Edit Permits changes to database data in the database viewer

Button_Database_Visible
  

Permits access to the database viewer

Button_Designer
  

Permits access to the Database Designer and Layout Designer with
all design features

Button_Import
 

Permits the import of key data in CSV format

Button_ImportLog
 

Permits access to the log file for the last import

Button_TemplateList
 

Permits the selection of a template

Button_TemplateRead
  

Permits the use of a template on a key read

Button_TemplateWrite
  

Permits the creation of a template

Button_UserManager
  

Permits access to the user manager with all features for making
changes
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Button_Undo
 

Permits changes to key data to be discarded

Button_WriteKey
 

Permits writing to keys

In addition to these rights, each form component must be enabled so that it is shown and can be
edited:

Once you have added form components in the design mode, the right Component_Name_Visible can
be assigned for each component in the user manager. With this right user groups can see the from
components added in the main window. 
For EKM database components it is also possible to assign the right Component_Name_Edit. With
this right user groups can change the data read from the key in the form component. 

3.10.2.2  Assigning rights to a group

Select a group by clicking the group in the window on the left.

Click the double arrow pointing to the left to assign all rights available to the selected group 

  

To assign a single right to the selected group, select a right by clicking it in the window on the
right. Then click the single arrow pointing to the left or press Ctrl + A.
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3.10.2.3  Removing rights from a group

Select a right from a group by clicking a right in the Groups window on the left. Click the arrow that
points to the right towards the Rights available window or press Ctrl + R.

A window opens where you can accept your selection using Yes if you want to remove the right from
the group.

3.10.3  Managing users

To display all the users already added, choose Users on the View tab. All users already added are
displayed in the window on the right under Users.
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3.10.3.1  Adding users

To add a new user, click Add on the User tab on the menu bar on the left. 

The Edit user window opens.

Complete all fields and accept your entries by clicking the OK button. 

You can enable the user profile for two different types of logon:

a) Log on with password:
On logon, the user enters his/her user name and password using the keyboard.

b) Log on with key:
On logon the user inserts his/her key in the EKS Electronic-Key adapter.

To activate log on with key, insert the key for the user you are editing in the EKS Electronic-Key
adapter. Read the KEYID by clicking the Detect key button. 

Activate the Log on with key check box. 
When you save the new user data using OK, the KEYID read will be saved in the user's profile.

If both logon types - log on with password and log on with key - are deactivated, the user profile is
inactive.  
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3.10.3.2  Editing users

To edit a user, select a user in the window on the right under Users by clicking it. Click Edit on the User
tab on the menu bar on the left. 

The Edit user window opens.

Enter your changes and accept them by clicking the OK button. 

To activate log on with key, insert the key for the user you are editing in the EKS Electronic-Key
adapter. Read the KEYID by clicking the Detect key button. 

Activate the Log on with key check box. When you save the new user data using OK, the KEYID read
will be saved in the user's profile.

If both logon types - log on with password and log on with key - are deactivated, the user profile is
inactive.    

If the user name is changed, all existing allocations to groups will be deleted. The user must be
allocated to a user group again.
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3.10.3.3  Deleting users

To delete a user, select a user by clicking the user. Click Delete on the User tab on the menu bar on
the left. 

A window opens where you can accept your selection using Yes if you want to delete the user.

3.10.3.4  Adding users to a group

Select a group by clicking the group in the window on the left. Then select a user by clicking a user in
the window on the right. Click the arrow that points to the left towards the Groups window or press
Ctrl + A.
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3.10.3.5  Removing users from a group

Select a user from a group by clicking a user in the Groups window on the left. Click the arrow that
points to the right towards the Users window or press Ctrl + R.

A window opens where you can accept your selection using Yes if you want to remove the user from
the group.



Subject to technical modification 093336-07-10/16Page 102/130

Manual Electronic-Key-Manager EKM

3.10.4  Loggin on and logging off users

To logon a different user without quitting the program, on the File menu click the Logon command. In
the Logon window enter the name and the password for the user who wants to logon.  

Accept your entries with OK. The program will be re-started and the user settings loaded. If logon using
key has been activated in your user profile, you can logon by inserting your key in the EKS Electronic-
Key adapter. If your user data are incorrect, you will receive a message:

On the second incorrect logon attempt, the program will close automatically. 

If you want to logoff, click the Logoff command on the File menu.  

Accept the logoff process.

The user rights are reset when you logoff. The Logon window opens.
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3.10.5  Changing password

If you want to change your password, on the File menu click Change password. In the Password
change window enter your old password and the new password; accept your entries with OK.

3.11  EKS interface

The EKS Electronic-Key adapter is connected to the computer over a serial port. You can select a port
for the device in the program. Select a COM port on the status bar in the main window:

If the selected port is not available or is use by another device, an error message is displayed. In this
case select a different COM port.

3.12  Server connection

You can change the connection parameters to the EKM server by:
Deleting the file ekm.INI in the program folder. The Connection parameters EKM-Server window
appears the next time the program is started (cf. "Installation"). Enter the new connection
parameters.
Opening the file ekm.INI and entering the new connection parameters under Server Address and
Server Port

3.13  Uninstalling

You can open the uninstall routine Uninstall EKM using the Windows Start menu.
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4  EKM server

4.1  Installation

You can use the EKM server as a service or as an application. The installation and removal of the server
vary depending on how the server is used. 

4.1.1  Installation as an application

To install the EKM server, add a new folder for the server and copy the file EKMServer.exe to the
program folder.

Start the application by double-clicking the file EKMServer.exe. The EKM server starts automatically.
You will see the EKM server icon in the notification area. 

Check the configuration of the EKM server in the server configuration wizard (cf. "Configuration of the
server" ). 
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4.1.2  Installation as service

To install the EKM server, add a new folder for the server and copy the file EKMServer.exe to the
program folder.

Install the service using the following command:
absolute path \EKMServer.exe /install  

On successful installation the following message is displayed:

You will find the EKM server as a service in the operating system in Services. The service starts
automatically when the computer is re-started. You will see the EKM server icon in the notification area.

Check the configuration of the EKM server in the server configuration wizard (cf. "Configuration of the
server"). 

The EKM server icon in the notification area is not visible in all operating systems. Please use
in this case in the Windows start menu the program call EKM Admin (cf. “EKM Admin“) for the
configuration of the EKM server.
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4.1.3  EKM files

All files created from EKM are stored in the EKM installation path. 

When EKM is installed on Windows 7, Windows Server 2008 or Windows Server 2008 R2 and
the installation path is 'C:\Program Files\<EKM>',  the operation system redirects user specific
files to the VirtualStore. The VirtualStore is located under: 
'C:\Users\<User>\AppData\Local\VirtualStore\Program Files\<EKM>'. 

4.2  Starting the EKM server

Start the EKM server:
In your operating system in Services. The EKM server is listed as a service with the name EKM-
Server.
In the server configuration wizard (cf. "The server configuration wizard"). Click the Start Server button.
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4.3  Stopping the EKM server

Stop the service for the EKM server:

In Services in the operating system.  
In the server configuration wizard (cf. "The server configuration wizard" ). Click the Stop Server button.

 
If EKM users are connected to the EKM server, the following messages are displayed. Accept the
messages with Yes if you want to stop the EKM server service:
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When you exit the EKM server, a warning is displayed to the users:

4.4  Uninstalling

You can use the EKM server as a service or as an application. The installation and removal of the server
vary depending on how the EKM server is used. 

4.4.1  Uninstalling the EKM server as application

If you installed the EKM server as an application and started the server, you only need to quit the
application to uninstall the EKM server. Click the EKM server icon in the notification area using the right
mouse button. 

The EKM server context menu opens. Click the Close command. 

The EKM server icon disappears from the notification area. If you no longer want to use the EKM server,
you can delete the program folder containing the file EKMServer.exe.

4.4.2  Uninstalling the EKM server as service

To uninstall the EKM server service, use the following command:

absolute path \EKMServer.exe /uninstall  

On a successful uninstall the following message is displayed:

The EKM server will no longer be listed in Services in the operating system when the computer is re-
started.
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4.5  The server configuration wizard

Open the configuration wizard by ...

Double-clicking the EKM server icon in the notification area.

Opening the context menu by clicking the EKM service icon in the notification area using the right
mouse button and clicking the Properties command. 

The server configuration wizard opens. Click the Properties tab and stop the EKM server by clicking the
Stop Server button. 

In the server configuration wizard you can:

Configure the server
Set the type of key used
Display log entries
Display users logged on
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4.5.1  Configuration of the server

To configure the EKM server, you must first stop the server. The configuration options are only available
after the server has been stopped: 

You can see the default settings in the figure. As a rule the options set on installation do not need to be
changed. If necessary, the log function can be switched off to improve performance.  

Server Configuration:
 

IP Address IP address used by the EKM server for the communication with the clients.
Normally Automatic should be entered here. The EKM server can then communicate
using all available network cards. If there are several network cards in the machine and
communication is only to take place using a specific card, enter the IP address for this
network card.

 

Port
 

TCP/IP port
 

Autostart
 

Activated: the EKM server is ready for communication immediately after program start.
 

Service-GUI
 

Activated: the EKM server icon appears in the notification area when the EKM server is
installed as a service.

Database Connection: Displays the key database folder used.

Electronic-Key-Type:
 

Read/Write Key type that it is allowed to read and write.
Read-Only Key type that can only be read
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You can also enter all parameters directly in the configuration file EKMServer.ini using a text editor: 

Section Configuration entry
[Server] AutoStart=0|1

Port==<PortNumber>
IPAddress=Automatic|<IPAddress>|<ComputerName>
ShowTrayIcon=1|0

[KeyType] ReadOnlyKey=1|0

The server must be stopped to be able to make changes to the configuration. For this purpose
click the Stop Server button. During this process the connection to all clients is interrupted.

4.5.2  Log-Properties

Click the Log-Properties tab in the server configuration wizard to define the behavior of the server logger
and the key logger.

Logger (=server logger):
 

Write Logfile Activated: a log file is written per day. The file name comprises the current date
and a file name that can be defined as required: 

<YYYY>_<MM>_<DD>_<file name>.txt 

Enter a file name and path in Logfile. Use the browse button in the Logfile field to
select a folder. 
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Logfile Path and file name for the log file to which the server logger is to be written.

The default file name is ekm.txt. The default folder is the EKM server installation
folder.

Example: 
Directory: C:\Temp\ekm.txt
Log day: 26 April 2006
The following log file is created in the folder C:\Temp\ for 26 April 2006:
2006_04_24_ekm.txt

 

Delete logfiles
after X days

 

All log files are deleted after X days..

 Online-Logger  Activated: the server logger is displayed on the EKM server in Logger.

Key-Logger (=logger for keys inserted):
 

Write Logfile Activated: a log file is written per day. The file name comprises the current date and
a file name that can be defined as required: 

<YYYY>_<MM>_<DD>_<file name>.txt 

Enter a file name and path in Logfile. Use the browse button in the Logfile field to
select a folder.

Logfile  Path and file name for the log file to which the key logger is to be written.

The default file name is key.txt. The default folder is the EKM server installation
folder.

Example: 
Directory: C:\Temp\key.txt
Log day: 26 April 2006
The following log file is created in the folder C:\Temp\ for 26 April 2006:
2006_04_26_key.txt

 

Delete logfiles
after X days

 

All log files are deleted after X days.

 

Online-Logger
 

Activated: the key logger is displayed on the EKM server in Key-Logger.
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4.5.3  Logger

In the server configuration wizard click the Logger tab. Log entries on the EKM server are displayed.

The Online-Logger option in Log-Properties: Logger must be activated to display the log entries in
the EKM server window.

The online logger is deleted when the EKM server is re-started.  The log entries in the online logger
are overwritten after 500 entries.

Example log messages:

Log message Explanation

Connected... A client has connected to the EKM server.

Login... A client is logging onto the EKM server. 

Select SQL... Database query

Update SQL... Changes to data in the database

Insert SQL... Insertion of data in the database
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4.5.4  Key-Logger

In the server configuration wizard click the Key-Logger tab. The Key-Logger records the Key-In and Key-
Out events:

Key-In: A key is inserted in the EKS Electronic-Key adapter
Key-Out: A key is removed from the EKS Electronic-Key adapter.

Date, time and KEYID are also logged with the events.

The Online-Logger option in Log-Properties: Key-Logger must be activated to display the log
entries in the EKM server window.

The online key-logger is deleted when the EKM server is re-started. The log entries in the online
key-logger are overwritten after 500 entries.
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4.5.5  Users logged on

Click the Users tab in the server configuration wizard. All clients connected to the EKM server are
logged on.
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4.5.6  Export functions

Click the Export tab in the server configuration wizard to define the CSV or SmartCard export functions.
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CSV-Export

During a CSV export all key data with the exception of the Memo, Graphic and StringPassword
data types are exported. You have two options for the export:

a) Start export after any change
The key data are exported to a CSV file. 
The first row in the export file contains the names of the database fields
Order of the database fields:

Database field KEYID
Database field LOCKED
Database fields of the key data. The sequence is the same as the order on the key.
Remaining database fields. The sequence is the same as the order defined in the Database
Designer

b) Start export and external customized conversion program after any change
The key data are exported to a temporary CSV file.
To setup the temporary export file: see CSV-Export a) 
After the export to CSV the external program for processing the data from the CSV file is
opened.
A further export can only be triggered if the temporary CSV file has been deleted.
Example for possible applications:
An application that encrypts key data is used. When opened the application accesses the CSV
export file, processes the key data and outputs the encrypted data in another file. Once the
process is complete, the CSV export file is deleted by the application.
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SmartCard export:

The serial numbers of the keys (KEYID) are converted to the card code for the SmartCard and
saved as file names for zero-byte files.

The file names have the following syntax:

USERMAN_CARDxxxxxxxx
(xxxxxxxx stands for the card code).

Locked keys are not saved or deleted.

The key serial number is a sixteen digit hexadecimal number (8 bytes). For the conversion to the
card code this number must be converted into an eight digit hexadecimal number (4 bytes): 

The 8 byte key serial number is divided into two 4 byte values.
The two 4 byte values are added together. Any overflow is ignored. The resulting 4 byte value is
the card code. 
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To activate an export function, proceed as follows:

CSV export: 

a) Start export after any change

In the Export-File field enter an export file and path. During this process you can use the open or browse
dialog box by clicking the button in the Export-File field. 

Activate the related check box for the export:

The CSV export is performed automatically after every change to the key data.

b) Start export and external customized conversion program after any change

In the Export-File field enter an export file and path. During this process you can use the open or browse
dialog box by clicking the button in the Export-File field. 

In the External Program field enter an exe file and path. During this process you can use the open or
browse dialog box by clicking the button in the External-Program field.

Activate the related check box for the export.
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After every change to the key data it is checked whether a temporary file exists. If there is no temporary
export file, the key data are exported. After the CSV export the defined application is started by the
EKM server.

SmartCard export:

Enter an export folder and path in the Export-Folder field. During this process you can use the open or
browse dialog box by clicking the button in the Export-Folder field.

Activate the check box for the export:

The SmartCard export gets initiated, respectively a data synchronisation between EKM database and
SmartCard export folder is carried out, when:

the SmartCard export gets activated in the check box Start export after any change when the server
is running
the server gets started and SmartCard export is already activated

After activation of the SmartCard export function in the server, in the configuration file EKMServer.ini an
entry [SmartCard-Export] is automatically generated.

When the server is running, an automatic data synchronisation takes place between EKM database and
SmartCard export folder. The default value for the cyclic synchronisation is 24 hours. This value applies
without further entry in the configuration file.

Alternatively a time interval for the automatic data synchronisation in deviation to the default value (24
hours) can be set in the configuration file EKMServer.ini. For this, add the following configuration entry
in the configuration file EKMServer.ini:

Section Configuration entry
[SmartCard-Export] Check interval=<time in hours>

Valid entries for the time in hours are values in whole numbers 1, 2, 3 through n. For the data
synchronisation in a time interval of 2 hours, the configuration entry Check interval=2 is required for
example. For the data synchronisation in a time interval of 2 days, the configuration entry Check
interval=48 is required for example.

The server must be stopped to be able to make changes to the configuration. For this purpose
click the Stop Server button. During this process the connection to all clients is interrupted.

Changes in the SmartCard export folder are carried out when:

Key establishing: related SmartCard file is created
Key deleting: related SmartCard file is deleted
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Key locking: related SmartCard file is deleted
Key unlocking: related SmartCard file is created

On changes of data which are stored on the key, respectively are assigned to the key via data base,
there is no export. 

When SmartCard export is activated, the export and synchronisation activities are recorded in the 
Logger (cf. “Logger”), provided that it is activated in the server.

When the server is stopped or the export gets deactivated in the check box Start export after any
change when the server is running, then the SmartCard files remain in the SmartCard export folder
without change.

4.6  Update function

Electronic-Key-Manager EKM features an automatic update function for the EKM client as well as for
the EKM online help. For this purpose the folder "ClientVersion" is automatically added to the program
path for the EKM server on program start. You can save more recent versions of the EKM client and the
EKM online help in this folder.

4.6.1  EKM client update

If a new version of the EKM client is available, copy the file EKM.EXE to the EKM server's
"ClientVersion" folder. To apply the new version, stop and start the EKM server. All EKM clients will
receive the new version on the next logon. On the application of the new functions the EKM client is
automatically quit and re-started.  

4.6.2  EKM online help update

If a new version of the EKM online help is available, copy the files EKM_D.CHM und EKM_E.CHM to
the EKM server's ClientVersion folder. To apply the new version, stop and start the EKM server. All
EKM clients will receive the new version on the next logon. 
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4.7  Data backup

All data that EKM clients edit are saved on the server in DB in the EKM server program folder:

The DB folder contains the following sub-folders and files:

 Backup folder  Layout  Database files

The database contains:

All key data
All user data

The layout for the key data form is saved separately in the file ekmDesign.dfm. When a user opens the
design mode, a backup copy of the last valid design is saved in the backup folder: The folder containing
the backups copies in Backups is named using the current date and time. Depending on the changes
made in the design mode, database files and / or the file ekmDesign.dfm are restored.

Backup up the folder DB at regular intervals.      
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4.8  User-specific logo

The logo displayed in EKM client can be replaced with a user-specific logo. Save the required logo as a
file with the name "CompanyLogo.Bmp". Then copy the file to the sub-folder "DB" on the EKM server
application path. All EKM clients will receive the user-specific logo the next time they logon. The logo
image size is 150 (wide) x 40 (high) pixels.
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5  EKM-Admin

EKM admin is used to configurate the EKM server. The user interface and functionality are the same as
for the EKM server.

EkmAdmin.exe und EKMServer.exe are located in the same folder.

To activate the EKM admin, add following entry in the configuration file EKMServer.ini:

Section Configuration entry
[Server] AdminPort=<port number>
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